summaryrefslogtreecommitdiffstats
path: root/main/audacious-plugins
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-08 16:57:18 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-08 16:57:34 -0500
commit94e9b1305b2c4bd2b45db58cb86fad0fb7ca05c3 (patch)
tree676be3ccb4b3b535f8c6bc455e21d616d5e3db30 /main/audacious-plugins
parente355b43b59358f977236b3e4ca47c5ae7f75fa2a (diff)
downloadaports-94e9b1305b2c4bd2b45db58cb86fad0fb7ca05c3.tar.bz2
aports-94e9b1305b2c4bd2b45db58cb86fad0fb7ca05c3.tar.xz
main/audacious-plugins: fix for upstream AUDPLUG-369
Diffstat (limited to 'main/audacious-plugins')
-rw-r--r--main/audacious-plugins/APKBUILD8
-rw-r--r--main/audacious-plugins/audacious-plugins-2.5.1-vorbis.patch54
2 files changed, 59 insertions, 3 deletions
diff --git a/main/audacious-plugins/APKBUILD b/main/audacious-plugins/APKBUILD
index 5e212aac3..b44309f12 100644
--- a/main/audacious-plugins/APKBUILD
+++ b/main/audacious-plugins/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=audacious-plugins
pkgver=2.5.1
-pkgrel=0
+pkgrel=1
pkgdesc="playlist-oriented media player with multiple interfaces (plugins)"
url="http://audacious-media-player.org/"
arch="all"
@@ -45,7 +45,8 @@ makedepends="libmowgli-dev
autoconf"
install=
subpackages=
-source="http://distfiles.atheme.org/$pkgname-$pkgver.tgz"
+source="http://distfiles.atheme.org/$pkgname-$pkgver.tgz
+ audacious-plugins-2.5.1-vorbis.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -84,4 +85,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="809d4429d3fbe51f9c19479c3138e6d7 audacious-plugins-2.5.1.tgz"
+md5sums="809d4429d3fbe51f9c19479c3138e6d7 audacious-plugins-2.5.1.tgz
+891db73ec2d00343d06f0a64a57456ac audacious-plugins-2.5.1-vorbis.patch"
diff --git a/main/audacious-plugins/audacious-plugins-2.5.1-vorbis.patch b/main/audacious-plugins/audacious-plugins-2.5.1-vorbis.patch
new file mode 100644
index 000000000..0e35adff3
--- /dev/null
+++ b/main/audacious-plugins/audacious-plugins-2.5.1-vorbis.patch
@@ -0,0 +1,54 @@
+From 6ed2a39924b29f185e5a87bd8dccffaa0f1011ca Mon Sep 17 00:00:00 2001
+From: John Lindgren <john.lindgren@tds.net>
+Date: Wed, 08 Jun 2011 18:49:57 +0000
+Subject: vorbis: Patch from Michael Schwendt to fix crash on 32-bit systems. Closes: AUDPLUG-369.
+
+---
+diff --git a/src/vorbis/vcedit.c b/src/vorbis/vcedit.c
+index 9dd6c01..dc14d2f 100644
+--- a/src/vorbis/vcedit.c
++++ b/src/vorbis/vcedit.c
+@@ -145,7 +145,7 @@ _fetch_next_packet(vcedit_state * s, ogg_packet * p, ogg_page * page)
+ {
+ int result;
+ char *buffer;
+- int bytes;
++ gint64 bytes;
+
+ result = ogg_stream_packetout(s->os, p);
+
+@@ -189,7 +189,7 @@ vcedit_open_callbacks(vcedit_state * state, void *in,
+ vcedit_write_func write_func)
+ {
+ char *buffer;
+- int bytes, i;
++ gint64 bytes, i;
+ ogg_packet *header;
+ ogg_packet header_main;
+ ogg_packet header_comments;
+@@ -317,7 +317,7 @@ vcedit_write(vcedit_state * state, void *out)
+ ogg_int64_t granpos = 0;
+ int result;
+ char *buffer;
+- int bytes;
++ gint64 bytes;
+ int needflush = 0, needout = 0;
+
+ state->eosin = 0;
+diff --git a/src/vorbis/vcedit.h b/src/vorbis/vcedit.h
+index 983a2ee..ea4432f 100644
+--- a/src/vorbis/vcedit.h
++++ b/src/vorbis/vcedit.h
+@@ -19,8 +19,8 @@ extern "C" {
+ #include <vorbis/codec.h>
+ #include <audacious/plugin.h>
+
+-typedef size_t (*vcedit_read_func)(void *, size_t, size_t, void *);
+-typedef size_t (*vcedit_write_func)(const void *, size_t, size_t, void *);
++typedef gint64 (*vcedit_read_func)(void *, gint64, gint64, void *);
++typedef gint64 (*vcedit_write_func)(const void *, gint64, gint64, void *);
+
+ typedef struct {
+ ogg_sync_state *oy;
+--
+cgit v0.8.3.4