summaryrefslogtreecommitdiffstats
path: root/main/bison
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-30 17:41:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-30 17:41:10 +0000
commit9cd3b9efafacf6b94cf1098e5e00cf239b6de446 (patch)
tree7e5989d39431dc5daebdb05a6c348160ed27e6e3 /main/bison
parent4fe58eca059e61cda63b82b4fede532db09a8d15 (diff)
downloadaports-9cd3b9efafacf6b94cf1098e5e00cf239b6de446.tar.bz2
aports-9cd3b9efafacf6b94cf1098e5e00cf239b6de446.tar.xz
main/bison: upgrade to 2.4.2
Diffstat (limited to 'main/bison')
-rw-r--r--main/bison/APKBUILD24
-rw-r--r--main/bison/gnulib-uclibc.patch13
2 files changed, 31 insertions, 6 deletions
diff --git a/main/bison/APKBUILD b/main/bison/APKBUILD
index c0de867ea..f24dd7441 100644
--- a/main/bison/APKBUILD
+++ b/main/bison/APKBUILD
@@ -1,22 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bison
-pkgver=2.4.1
-pkgrel=5
+pkgver=2.4.2
+pkgrel=0
pkgdesc="The GNU general-purpose parser generator"
license="GPL"
url="http://www.gnu.org/software/bison/bison.html"
-depends="uclibc m4"
-source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.gz"
+depends="m4"
+source="ftp://ftp.gnu.org/gnu/bison/${pkgname}-${pkgver}.tar.gz
+ gnulib-uclibc.patch"
subpackages="$pkgname-doc"
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ patch -p1 -i "$srcdir"/gnulib-uclibc.patch
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure --prefix=/usr \
--datadir=/usr/share \
--infodir=/usr/share/info \
--mandir=/usr/share/man
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="c58aa1da418dc9704070872489e89bf5 bison-2.4.1.tar.gz"
+md5sums="6fc502f135738e98fecf1e5c8de38d62 bison-2.4.2.tar.gz
+20a7dedec0e9e0ee7107e33e798ffdbe gnulib-uclibc.patch"
diff --git a/main/bison/gnulib-uclibc.patch b/main/bison/gnulib-uclibc.patch
new file mode 100644
index 000000000..09775d6b1
--- /dev/null
+++ b/main/bison/gnulib-uclibc.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/spawn.in.h b/lib/spawn.in.h
+index 84ba93c..6df4599 100644
+--- a/lib/spawn.in.h
++++ b/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#if !defined(__GLIBC__) || defined(__UCLIBC__)
+ # include <sched.h>
+ # include <signal.h>
+ #endif