summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-09 22:22:53 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-09 22:22:53 -0600
commit8510fd0a6ab8ad9e3169b55059bd33953b70cf74 (patch)
tree52f52e1f4510b7cec2b4c95e6c08ab4e7cb52cc9 /main/busybox
parent3f8d492d0e94b07cefe475aa3a731c32d4b47e70 (diff)
downloadaports-8510fd0a6ab8ad9e3169b55059bd33953b70cf74.tar.bz2
aports-8510fd0a6ab8ad9e3169b55059bd33953b70cf74.tar.xz
main/busybox: support crosscompiling
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index d49911917..f811abb81 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -40,14 +40,14 @@ build() {
-e "s/.*CONFIG_STATIC.*/CONFIG_STATIC=y/" \
"$_config" > .config
make silentoldconfig || return 1
- make || return 1
+ make CROSS_COMPILE="${CHOST}-" || return 1
mv busybox busybox.static
# build dynamic
msg "Building dynamic busybox"
cp "$_config" .config
make silentoldconfig || return 1
- make || return 1
+ make CROSS_COMPILE="${CHOST}-" || return 1
}
package() {