summaryrefslogtreecommitdiffstats
path: root/main/busybox
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-02-10 23:48:53 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-02-10 23:50:29 -0600
commitdcec1161e5c692bfca7fbb51dec3968c3c3dbf98 (patch)
tree4efad4712af142fd6ab75cb19ba3bddaf47841c9 /main/busybox
parent280577f0ebeaed2ca082bf98c10bb7e53af5cab0 (diff)
downloadaports-dcec1161e5c692bfca7fbb51dec3968c3c3dbf98.tar.bz2
aports-dcec1161e5c692bfca7fbb51dec3968c3c3dbf98.tar.xz
main/busybox: kill gnu/linux nonsense
Diffstat (limited to 'main/busybox')
-rw-r--r--main/busybox/APKBUILD4
-rw-r--r--main/busybox/busybox-uname-is-not-gnu.patch20
2 files changed, 23 insertions, 1 deletions
diff --git a/main/busybox/APKBUILD b/main/busybox/APKBUILD
index f811abb81..8ea56af00 100644
--- a/main/busybox/APKBUILD
+++ b/main/busybox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=busybox
pkgver=1.18.2
-pkgrel=0
+pkgrel=1
pkgdesc="Size optimized toolbox of many common UNIX utilities"
url=http://busybox.net
arch="all"
@@ -12,6 +12,7 @@ subpackages="$pkgname-static"
triggers="busybox.trigger:/bin /usr/bin /sbin /usr/sbin /lib/modules/*"
source="http://busybox.net/downloads/$pkgname-$pkgver.tar.bz2
$pkgname-1.11.1-bb.patch
+ busybox-uname-is-not-gnu.patch
busyboxconfig"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -70,4 +71,5 @@ static() {
md5sums="69a82091e5710b72db5ce0e14e7c0cd7 busybox-1.18.2.tar.bz2
4c0f3b486eaa0674961b7ddcd0c60a9b busybox-1.11.1-bb.patch
+b5375210f13fd6e1ca61a565e8fabd35 busybox-uname-is-not-gnu.patch
181310149cad8fce22aba96220cbbd38 busyboxconfig"
diff --git a/main/busybox/busybox-uname-is-not-gnu.patch b/main/busybox/busybox-uname-is-not-gnu.patch
new file mode 100644
index 000000000..95b31394c
--- /dev/null
+++ b/main/busybox/busybox-uname-is-not-gnu.patch
@@ -0,0 +1,20 @@
+--- busybox-1.18.2.orig/coreutils/uname.c
++++ busybox-1.18.2/coreutils/uname.c
+@@ -56,7 +56,7 @@
+ struct utsname name;
+ char processor[sizeof(((struct utsname*)NULL)->machine)];
+ char platform[sizeof(((struct utsname*)NULL)->machine)];
+- char os[sizeof("GNU/Linux")];
++ char os[sizeof("Linux")];
+ } uname_info_t;
+
+ static const char options[] ALIGN1 = "snrvmpioa";
+@@ -123,7 +123,7 @@
+ #endif
+ strcpy(uname_info.processor, unknown_str);
+ strcpy(uname_info.platform, unknown_str);
+- strcpy(uname_info.os, "GNU/Linux");
++ strcpy(uname_info.os, "Linux");
+ #if 0
+ /* Fedora does something like this */
+ strcpy(uname_info.processor, uname_info.name.machine);