summaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-18 19:56:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-18 19:56:51 +0000
commit4d2874466bde34517eecc71310494ce1ccc43854 (patch)
treef0ba3118bc5bcf970e130788cae54b5f563ab6bf /main/curl
parente27a02bc63070e559f8648a333d035a15f09a1d8 (diff)
downloadaports-4d2874466bde34517eecc71310494ce1ccc43854.tar.bz2
aports-4d2874466bde34517eecc71310494ce1ccc43854.tar.xz
main/curl: fix curl-config --version
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD17
-rw-r--r--main/curl/curl-version.patch11
2 files changed, 25 insertions, 3 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 425a3a628..4ff39e246 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
pkgver=7.21.5
-pkgrel=0
+pkgrel=1
pkgdesc="An URL retrival utility and library"
url="http://curl.haxx.se"
arch="all"
@@ -9,11 +9,21 @@ license="MIT"
depends=
depends_dev="zlib-dev openssl-dev"
makedepends="$depends_dev"
-source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2"
+source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2
+ curl-version.patch"
subpackages="$pkgname-doc $pkgname-dev"
_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -29,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="dadd6353c9407161ddd62c0943718d59 curl-7.21.5.tar.bz2"
+md5sums="dadd6353c9407161ddd62c0943718d59 curl-7.21.5.tar.bz2
+e49c54f1890f380e2617dbd58600fe6e curl-version.patch"
diff --git a/main/curl/curl-version.patch b/main/curl/curl-version.patch
new file mode 100644
index 000000000..527973d48
--- /dev/null
+++ b/main/curl/curl-version.patch
@@ -0,0 +1,11 @@
+--- ./curl-config.in.orig
++++ ./curl-config.in
+@@ -94,7 +94,7 @@
+ ;;
+
+ --version)
+- echo libcurl @VERSION@
++ echo libcurl @CURLVERSION@
+ exit 0
+ ;;
+