summaryrefslogtreecommitdiffstats
path: root/main/db
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2012-02-11 00:27:19 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2012-02-11 00:27:19 -0600
commit5d7f87f856d5ab5c13148f781a309af5c9ceff02 (patch)
tree29117de3754def7e64957104fa8a9dbbd84435fa /main/db
parentd81190b1426d5294ebe6f099ebd2225f806d8358 (diff)
downloadaports-5d7f87f856d5ab5c13148f781a309af5c9ceff02.tar.bz2
aports-5d7f87f856d5ab5c13148f781a309af5c9ceff02.tar.xz
main/db: add db-c++ subpackage
Diffstat (limited to 'main/db')
-rw-r--r--main/db/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/main/db/APKBUILD b/main/db/APKBUILD
index 74bd95259..22264f954 100644
--- a/main/db/APKBUILD
+++ b/main/db/APKBUILD
@@ -2,14 +2,14 @@
pkgname=db
pkgver=5.3.15
_ver=${pkgver}
-pkgrel=0
+pkgrel=1
pkgdesc="The Berkeley DB embedded database system"
url="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
arch="all"
license="custom"
depends=
makedepends=
-subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-c++:cxx"
# Patches were found here:
# http://www.oracle.com/technology/products/berkeley-db/db/update/4.7.25/patch.4.7.25.html
source="http://download.oracle.com/berkeley-db/db-$pkgver.tar.gz
@@ -28,8 +28,8 @@ build () {
--mandir=/usr/share/man \
--enable-compat185 \
--enable-shared \
- --disable-static \
- --disable-cxx
+ --enable-cxx \
+ --disable-static
make LIBSO_LIBS=-lpthread || return 1
}
@@ -52,4 +52,10 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
+cxx() {
+ pkgdesc="C++ binding for libdb"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libdb_cxx*.so "$subpkgdir"/usr/lib/
+}
+
md5sums="5493fb5f7cc3915887c836b096f18773 db-5.3.15.tar.gz"