summaryrefslogtreecommitdiffstats
path: root/main/fakeroot
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-02-10 08:57:13 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-02-10 08:57:13 +0200
commit49b10969569bb6d1e4332e91bf07c9ce7616fd76 (patch)
treef9ddb219a11633a97bd7cd869625c8f37d1769ae /main/fakeroot
parent0c902c0dc61e518d2ec2f0a0de3b636b91a3f44e (diff)
downloadaports-49b10969569bb6d1e4332e91bf07c9ce7616fd76.tar.bz2
aports-49b10969569bb6d1e4332e91bf07c9ce7616fd76.tar.xz
main/fakeroot: fix compilation warnings
Hopefully also fixes the issues we are seeing on 64-bit platforms.
Diffstat (limited to 'main/fakeroot')
-rw-r--r--main/fakeroot/APKBUILD10
-rw-r--r--main/fakeroot/fakeroot-stdint.patch34
-rw-r--r--main/fakeroot/fakeroot-uclibc.patch20
3 files changed, 61 insertions, 3 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
index 8fb54da73..eb933bdc2 100644
--- a/main/fakeroot/APKBUILD
+++ b/main/fakeroot/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fakeroot
pkgver=1.18.2
-pkgrel=0
+pkgrel=1
pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
arch="all"
license='GPL'
@@ -9,7 +9,9 @@ url="http://packages.debian.org/fakeroot"
depends=
subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
- busybox-getopt.patch"
+ busybox-getopt.patch
+ fakeroot-stdint.patch
+ fakeroot-uclibc.patch"
prepare() {
cd $startdir/src/$pkgname-$pkgver
@@ -33,4 +35,6 @@ package() {
}
md5sums="79f32331358ad58499704ea5e19fd0ae fakeroot_1.18.2.orig.tar.bz2
-bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch"
+bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch
+50a899380cfd5eae8ce3aaf878fb17b2 fakeroot-stdint.patch
+7a54ab51fdb90bc44e366e0a66811bfe fakeroot-uclibc.patch"
diff --git a/main/fakeroot/fakeroot-stdint.patch b/main/fakeroot/fakeroot-stdint.patch
new file mode 100644
index 000000000..bb4f67f0d
--- /dev/null
+++ b/main/fakeroot/fakeroot-stdint.patch
@@ -0,0 +1,34 @@
+--- fakeroot-1.18.2.orig/faked.c
++++ fakeroot-1.18.2/faked.c
+@@ -514,11 +514,11 @@
+
+ #ifdef FAKEROOT_DB_PATH
+ if (find_path(i->buf.dev, i->buf.ino, roots, path))
+- fprintf(f,"mode=%llo,uid=%llu,gid=%llu,nlink=%llu,rdev=%llu %s\n",
++ fprintf(f,"mode=%"PRIo64",uid=%"PRIu64",gid=%"PRIu64",nlink=%"PRIu64",rdev=%"PRIu64" %s\n",
+ (uint64_t) i->buf.mode,(uint64_t) i->buf.uid,(uint64_t) i->buf.gid,
+ (uint64_t) i->buf.nlink,(uint64_t) i->buf.rdev,path);
+ #else
+- fprintf(f,"dev=%llx,ino=%llu,mode=%llo,uid=%llu,gid=%llu,nlink=%llu,rdev=%llu\n",
++ fprintf(f,"dev=%"PRIx64",ino=%"PRIu64",mode=%"PRIo64",uid=%"PRIu64",gid=%"PRIu64",nlink=%"PRIu64",rdev=%"PRIu64"\n",
+ (uint64_t) i->buf.dev,(uint64_t) i->buf.ino,(uint64_t) i->buf.mode,
+ (uint64_t) i->buf.uid,(uint64_t) i->buf.gid,(uint64_t) i->buf.nlink,
+ (uint64_t) i->buf.rdev);
+@@ -544,7 +544,7 @@
+
+ while(1){
+ #ifdef FAKEROOT_DB_PATH
+- r=scanf("mode=%llo,uid=%llu,gid=%llu,nlink=%llu,rdev=%llu "DB_PATH_SCAN"\n",
++ r=scanf("mode=%"PRIo64",uid=%"PRIu64",gid=%"PRIu64",nlink=%"PRIu64",rdev=%"PRIu64" "DB_PATH_SCAN"\n",
+ &stmode, &stuid, &stgid, &stnlink, &strdev, &path);
+ if (r != 6)
+ break;
+@@ -559,7 +559,7 @@
+ stdev = path_st.st_dev;
+ stino = path_st.st_ino;
+ #else
+- r=scanf("dev=%llx,ino=%llu,mode=%llo,uid=%llu,gid=%llu,nlink=%llu,rdev=%llu\n",
++ r=scanf("dev=%"PRIx64",ino=%"PRIu64",mode=%"PRIo64",uid=%"PRIu64",gid=%"PRIu64",nlink=%"PRIu64",rdev=%"PRIu64"\n",
+ &stdev, &stino, &stmode, &stuid, &stgid, &stnlink, &strdev);
+ if (r != 7)
+ break;
diff --git a/main/fakeroot/fakeroot-uclibc.patch b/main/fakeroot/fakeroot-uclibc.patch
new file mode 100644
index 000000000..63708092d
--- /dev/null
+++ b/main/fakeroot/fakeroot-uclibc.patch
@@ -0,0 +1,20 @@
+--- fakeroot-1.18.2.orig/libfakeroot.c
++++ fakeroot-1.18.2/libfakeroot.c
+@@ -1551,7 +1551,7 @@
+ #endif /* LIBFAKEROOT_DEBUGGING */
+ r=next_fts_read(ftsp);
+ if(r && r->fts_statp) { /* Should we bother checking fts_info here? */
+-# if defined(STAT64_SUPPORT) && !defined(__APPLE__)
++# if defined(STAT64_SUPPORT) && !defined(__APPLE__) && !defined(__UCLIBC__)
+ SEND_GET_STAT64(r->fts_statp, _STAT_VER);
+ # else
+ SEND_GET_STAT(r->fts_statp, _STAT_VER);
+@@ -1574,7 +1574,7 @@
+ first=next_fts_children(ftsp, options);
+ for(r = first; r; r = r->fts_link) {
+ if(r && r->fts_statp) { /* Should we bother checking fts_info here? */
+-# if defined(STAT64_SUPPORT) && !defined(__APPLE__)
++# if defined(STAT64_SUPPORT) && !defined(__APPLE__) && !defined(__UCLIBC__)
+ SEND_GET_STAT64(r->fts_statp, _STAT_VER);
+ # else
+ SEND_GET_STAT(r->fts_statp, _STAT_VER);