summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-04 11:55:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-04 11:55:35 +0000
commit1036d9cd797d6da02598d3ed488f4b3fbfba422c (patch)
treef6e1a454ed3981b340837cde4faea3d9dee2e532 /main/firefox
parentf0433bbf020bbda6f8f1e67c1d4099cd4aa54a70 (diff)
downloadaports-1036d9cd797d6da02598d3ed488f4b3fbfba422c.tar.bz2
aports-1036d9cd797d6da02598d3ed488f4b3fbfba422c.tar.xz
main/firefox: fix launcher
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD39
-rw-r--r--main/firefox/firefox-5.0-asciidel.patch15
-rw-r--r--main/firefox/mozconfig11
3 files changed, 52 insertions, 13 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 423087581..bcfa444fd 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=7.0.1
_pkgver=$pkgver
_xulver=7.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -24,6 +24,7 @@ makedepends="xulrunner-dev>=${_xulver}
wireless-tools-dev
libnotify-dev
libevent-dev
+ libvpx-dev
libxt-dev
jpeg-dev
bzip2-dev
@@ -47,11 +48,13 @@ install=""
subpackages=""
source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver}/source/${pkgname}-${_pkgver}.source.tar.bz2
mozconfig
-
+ firefox-5.0-asciidel.patch
firefox.desktop
firefox-safe.desktop"
_builddir="${srcdir}/mozilla-release"
+_mozappdir=/usr/lib/firefox-$pkgver
+
prepare() {
local i
@@ -64,17 +67,20 @@ prepare() {
done
cp "${srcdir}/mozconfig" .mozconfig
+ echo "ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)" >> .mozconfig
}
build() {
cd "$_builddir"
- # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
- # for the best. --nenolod
- unset CFLAGS
- unset CXXFLAGS
+ # mozilla's buildsystem is on drugs
+ export CFLAGS="$(echo $CFLAGS | sed -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')"
+ export CXXFLAGS="$CFLAGS"
- make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+# export LDFLAGS="-Wl,-rpath,${_mozappdir}"
+ make -j1 -f client.mk build \
+ STRIP="/bin/true" \
+ MOZ_MAKE_FLAGS="$MAKEOPTS" || return 1
}
package() {
@@ -89,13 +95,24 @@ package() {
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
# firefox currently does not work with mprotect. disable it for now
- paxctl -c -m "$pkgdir"/usr/lib/firefox-$pkgver/firefox || return 1
+ paxctl -c -m "$pkgdir"/$_mozappdir/firefox || return 1
+
+ # xulrunner stub launcher has changed to using a symlink overlay...
+ # go figure
+ ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/$_mozappdir/xulrunner
+
+ # launcher as symlink is broken from firefox-7.0
+ rm "$pkgdir"/usr/bin/firefox || return 1
+ cat > "$pkgdir"/usr/bin/firefox << __EOF__
+#!/bin/sh
- # xulrunner stub launcher has changed to using a symlink overlay... go figure
- ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/usr/lib/firefox-${pkgver}/xulrunner
+exec $_mozappdir/firefox "\$@"
+__EOF__
+ chmod 755 "$pkgdir"/usr/bin/firefox
}
md5sums="5b212db48630ba93bb30ec63cca17f4d firefox-7.0.1.source.tar.bz2
-2381992b3c6eaa6bea013cb557385580 mozconfig
+90d21a0ca38d9da4e42f22982f8b8cc5 mozconfig
+2328df219e042f6aaec361cbf83cf9e9 firefox-5.0-asciidel.patch
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
diff --git a/main/firefox/firefox-5.0-asciidel.patch b/main/firefox/firefox-5.0-asciidel.patch
new file mode 100644
index 000000000..1916cb3b8
--- /dev/null
+++ b/main/firefox/firefox-5.0-asciidel.patch
@@ -0,0 +1,15 @@
+Patch from: Bill Nottingham <notting@redhat.com>
+
+diff -up mozilla-release/browser/base/Makefile.in.fu mozilla-release/browser/base/Makefile.in
+--- mozilla-release/browser/base/Makefile.in.fu 2011-06-24 16:50:23.802042086 -0400
++++ mozilla-release/browser/base/Makefile.in 2011-06-24 16:50:42.324042096 -0400
+@@ -62,7 +62,7 @@ EXTRA_JS_MODULES = \
+
+ include $(topsrcdir)/config/rules.mk
+
+-PRE_RELEASE_SUFFIX := ""
++PRE_RELEASE_SUFFIX :=
+
+ DEFINES += \
+ -DMOZ_APP_VERSION=$(MOZ_APP_VERSION) \
+
diff --git a/main/firefox/mozconfig b/main/firefox/mozconfig
index 83233ea54..add87aee8 100644
--- a/main/firefox/mozconfig
+++ b/main/firefox/mozconfig
@@ -6,6 +6,8 @@ ac_add_options --with-system-nspr
ac_add_options --with-system-nss
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
+ac_add_options --with-system-png
+ac_add_options --with-system-libvpx
ac_add_options --with-pthreads
ac_add_options --disable-tests
ac_add_options --disable-debug
@@ -14,7 +16,7 @@ ac_add_options --disable-installer
ac_add_options --enable-xinerama
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-xprint
-ac_add_options --enable-strip
+ac_add_options --disable-strip
ac_add_options --enable-pango
ac_add_options --enable-svg
ac_add_options --enable-canvas
@@ -22,10 +24,15 @@ ac_add_options --enable-startup-notification
ac_add_options --enable-libxul
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
-ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-7.0.1
ac_add_options --enable-safe-browsing
ac_add_options --enable-chrome-format=jar
ac_add_options --disable-elf-hack
+ac_add_options --enable-libnotify
+ac_add_options --disable-cpp-exceptions
+ac_add_options --enable-url-classifier
+ac_add_options --enable-gio
+ac_add_options --disable-gnomevfs
+ac_add_options --disable-static
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1