summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 12:26:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 12:26:45 +0000
commit4210c5090dd1ac6398b2ae68a081cda70857aa12 (patch)
tree9ff4e2cfa57ebde5758a2dcc9eac85e5f98a6922 /main/firefox
parent3b9c217df09ec2ec1a875dab2aca482c9f4fc027 (diff)
downloadaports-4210c5090dd1ac6398b2ae68a081cda70857aa12.tar.bz2
aports-4210c5090dd1ac6398b2ae68a081cda70857aa12.tar.xz
main/firefox: fix build against libvpx-1.0.0
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD4
-rw-r--r--main/firefox/libvpx.patch29
2 files changed, 32 insertions, 1 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 1c7a7277f..4ac9f722f 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=10.0.1
_pkgver=$pkgver
_xulver=10.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -49,6 +49,7 @@ subpackages=""
source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver}/source/${pkgname}-${_pkgver}.source.tar.bz2
mozconfig
firefox-5.0-asciidel.patch
+ libvpx.patch
firefox.desktop
firefox-safe.desktop"
@@ -118,5 +119,6 @@ __EOF__
md5sums="265c53120fd923c742164b0002ebbf6c firefox-10.0.1.source.tar.bz2
3ba2cb7cda675e78eb0eeb0652ee3457 mozconfig
2328df219e042f6aaec361cbf83cf9e9 firefox-5.0-asciidel.patch
+1084155dd8d32c488dfcafff336d2634 libvpx.patch
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
diff --git a/main/firefox/libvpx.patch b/main/firefox/libvpx.patch
new file mode 100644
index 000000000..503ac1bbc
--- /dev/null
+++ b/main/firefox/libvpx.patch
@@ -0,0 +1,29 @@
+--- configure.in.orig
++++ ./configure.in
+@@ -5616,7 +5616,7 @@
+ [MOZ_NATIVE_LIBVPX_DEC_TEST=1],
+ ([--with-system-libvpx requested but symbol vpx_codec_dec_init_ver not found]))
+ if test -n "$MOZ_NATIVE_LIBVPX_DEC_TEST" ; then
+- AC_MSG_CHECKING([for libvpx version >= v0.9.7])
++ AC_MSG_CHECKING([for libvpx version >= v1.0.0])
+ dnl We need at least v0.9.7 to fix several crash bugs (for which we
+ dnl had local patches prior to v0.9.7).
+ dnl
+@@ -5629,7 +5629,7 @@
+ dnl v0.9.6 one to check for.
+ AC_TRY_COMPILE([
+ #include <vpx/vpx_decoder.h>
+- #if !defined(VPX_CODEC_USE_INPUT_PARTITION)
++ #if !defined(VPX_CODEC_USE_INPUT_FRAGMENTS)
+ #error "test failed."
+ #endif
+ ],
+@@ -5639,7 +5639,7 @@
+ MOZ_LIBVPX_INCLUDES="-I${LIBVPX_DIR}/include"
+ MOZ_LIBVPX_LIBS="-L${LIBVPX_DIR}/lib -lvpx"],
+ [AC_MSG_RESULT([no])
+- AC_MSG_ERROR([--with-system-libvpx requested but it is not v0.9.7 or later])])
++ AC_MSG_ERROR([--with-system-libvpx requested but it is not v1.0.0 or later])])
+ fi
+ CFLAGS=$_SAVE_CFLAGS
+ LDFLAGS=$_SAVE_LDFLAGS