summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-07-10 22:32:11 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-07-10 22:32:11 -0500
commit4fe57a7b7e55c13493cbebfe555cfbccc750b8ee (patch)
treeaa5cf0355f921e22fd8ca493218fdf21d68f6eb0 /main/firefox
parent23fa9204d880044df5ed2eb6fe1036aff41bdf08 (diff)
downloadaports-4fe57a7b7e55c13493cbebfe555cfbccc750b8ee.tar.bz2
aports-4fe57a7b7e55c13493cbebfe555cfbccc750b8ee.tar.xz
main/firefox: update to 5.0.
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD19
-rw-r--r--main/firefox/mozconfig3
2 files changed, 13 insertions, 9 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 8b77f0741..628634e35 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=firefox
-pkgver=4.0.1
-_pkgver=4.0.1
-_xulver=2.0.1
-pkgrel=2
+pkgver=5.0
+_pkgver=5.0
+_xulver=5.0
+pkgrel=0
pkgdesc="firefox web browser"
url="http://www.firefox.com"
arch="all"
@@ -15,6 +15,7 @@ makedepends="xulrunner-dev>=${_xulver}
nspr-dev
nss-dev
gtk+-dev
+ mesa-dev
dbus-glib-dev
alsa-lib-dev
libvorbis-dev
@@ -50,8 +51,7 @@ source="http://releases.mozilla.org/pub/mozilla.org/${pkgname}/releases/${pkgver
firefox.desktop
firefox-safe.desktop"
-_xulrunner_version="2.0"
-_builddir="${srcdir}/mozilla-${_xulrunner_version}"
+_builddir="${srcdir}/mozilla-release"
prepare() {
local i
@@ -89,9 +89,12 @@ package() {
# firefox currently does not work with mprotect. disable it for now
paxctl -c -m "$pkgdir"/usr/lib/firefox-$pkgver/firefox
+
+ # xulrunner stub launcher has changed to using a symlink overlay... go figure
+ ln -sf /usr/lib/xulrunner-${_xulver} ${pkgdir}/usr/lib/firefox-${pkgver}/xulrunner
}
-md5sums="9abda7d23151e97913c8555a64c13f34 firefox-4.0.1.source.tar.bz2
-0b341845d311fe6b49f74751e4841ee6 mozconfig
+md5sums="9f64a01e86a5d424e12a8e3305c5debe firefox-5.0.source.tar.bz2
+0d34447eb5e9c1d96fb29bd00cd5fc98 mozconfig
ba96924ece1d77453e462429037a2ce5 firefox.desktop
6f38a5899034b7786cb1f75ad42032b8 firefox-safe.desktop"
diff --git a/main/firefox/mozconfig b/main/firefox/mozconfig
index 1ec6b90b3..090477ae1 100644
--- a/main/firefox/mozconfig
+++ b/main/firefox/mozconfig
@@ -22,10 +22,11 @@ ac_add_options --enable-startup-notification
ac_add_options --enable-libxul
ac_add_options --disable-crashreporter
ac_add_options --disable-updater
-ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-2.0.1
+ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-5.0
ac_add_options --enable-safe-browsing
ac_add_options --with-branding=other-licenses/branding/firefox
ac_add_options --enable-chrome-format=jar
+ac_add_options --disable-elf-hack
export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1