summaryrefslogtreecommitdiffstats
path: root/main/fprobe
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-03 07:10:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-03 07:11:59 +0000
commit513a07446e02609236cb81228151f9c554b41c18 (patch)
tree3a9e240ce4af2fe3a016055d31330e642cbefc83 /main/fprobe
parentac17c674ac2deded5e730fb21ccd7480930360ea (diff)
downloadaports-513a07446e02609236cb81228151f9c554b41c18.tar.bz2
aports-513a07446e02609236cb81228151f9c554b41c18.tar.xz
main/fprobe: fix shell variable expansion bug in init.d script
ref #990
Diffstat (limited to 'main/fprobe')
-rw-r--r--main/fprobe/APKBUILD4
-rwxr-xr-x[-rw-r--r--]main/fprobe/fprobe.initd5
2 files changed, 5 insertions, 4 deletions
diff --git a/main/fprobe/APKBUILD b/main/fprobe/APKBUILD
index 7c653ed71..79da613cf 100644
--- a/main/fprobe/APKBUILD
+++ b/main/fprobe/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=fprobe
pkgver=1.1
-pkgrel=5
+pkgrel=6
pkgdesc="libpcap-based tool that collect network traffic"
url="http://fprobe.sourceforge.net/"
arch="all"
@@ -48,5 +48,5 @@ package() {
md5sums="65850d0470078269b33eee58cba77ac2 fprobe-1.1.tar.bz2
265c9d9c434df46fc224a1ce7051e27a fprobe-1.1-pidfile-sanity.patch
ba8632d883fb49e83ea16db67c50a69b fprobe-1.1-setgroups.patch
-41810a73503624de2c27809e34ed80b4 fprobe.initd
+6dba73f47bd466c586a836d6f26fb712 fprobe.initd
ba9c9327456e4db897b60481705df282 fprobe.confd"
diff --git a/main/fprobe/fprobe.initd b/main/fprobe/fprobe.initd
index a14f1e6bc..d4fed4e8c 100644..100755
--- a/main/fprobe/fprobe.initd
+++ b/main/fprobe/fprobe.initd
@@ -15,8 +15,9 @@ PIDFILE="/var/run/fprobe$PIDFILE_EXTRA.pid"
start() {
ebegin "Starting fprobe"
local OPTS=""
+ set --
[ "${PROMISC}" == "yes" ] || OPTS="${OPTS} -p"
- [ -n "${FILTER}" ] && OPTS="${OPTS} -f '${FILTER}'"
+ [ -n "${FILTER}" ] && set -- -f "${FILTER}"
for optname in i:IFACE s:TIMER_EXPIRED g:TIME_FRAGMENTED d:TIMER_IDLE \
e:TIMER_ACTIVE n:FLOW_VER a:LOCALIP x:SNMP_IFACE b:MEMBULK \
m:MEMLIMIT q:PENDING B:KERNBUF r:RTPRIO t:DELAY S:SNAPLEN \
@@ -28,7 +29,7 @@ start() {
OPTS="${OPTS} -l 1:${PIDFILE_ID} ${COLLECTORS}"
start-stop-daemon --start --exec $BIN \
--pidfile ${PIDFILE} \
- -- ${OPTS}
+ -- "$@" ${OPTS}
eend $?
}