summaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2010-05-06 15:19:06 +0000
committerMichael Mason <ms13sp@gmail.com>2010-05-06 15:19:06 +0000
commit35c81ce5b042347317736d23b2d6e5c056f00c05 (patch)
treeb8d387456dbcdd8b45fbe54a025b84311e852ccd /main/freeswitch/APKBUILD
parent75ff374836b4debeac557416f3ad156d3bd38b35 (diff)
downloadaports-35c81ce5b042347317736d23b2d6e5c056f00c05.tar.bz2
aports-35c81ce5b042347317736d23b2d6e5c056f00c05.tar.xz
freeswitch bug fixes for freswitch user and rundir
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 241b70641..22d59f38b 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
pkgname=freeswitch
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
license="GPL"
@@ -31,7 +31,8 @@ build() {
--sysconfdir=/etc/freeswitch \
--with-modinstdir=/usr/lib/freeswitch \
--mandir=/usr/share/man \
- --infodir=/usr/share/info
+ --infodir=/usr/share/info \
+ --without-rundir
# check how/when parallel builds are fixed here:
# http://jira.freeswitch.org/browse/FSBUILD-6
@@ -51,6 +52,7 @@ build() {
package(){
cd "$srcdir/$pkgname-$pkgver"
make -j1 DESTDIR="$pkgdir" install
+ mkdir "$pkgdir"/var/run/freeswitch
install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
@@ -60,5 +62,5 @@ c05f2356be159e99b3845f5260a33599 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
dd3a6535c54fc6ed8399d6bb57d88369 freeswitch.initd
c0d7ad55063b1f62c9a2fcfa37b2fc0a freeswitch.post-install
-a34305ba1f8a8e7e6dbb9c678cc442b9 freeswitch.pre-install
+661e2dff4022522b95c875f2f88aa66a freeswitch.pre-install
a7188703019a74fd7f128d165b3ecf42 freeswitch.post-deinstall"