summaryrefslogtreecommitdiffstats
path: root/main/gamin
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-28 08:03:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-28 11:54:40 +0000
commite944709cd8381af07e711986f73d02e3e1e9391f (patch)
tree441f5923c9019f65b309e893aaafece7f1841e2e /main/gamin
parentb8da78bc3d6bda250c5305b520324579d7c50d9f (diff)
downloadaports-e944709cd8381af07e711986f73d02e3e1e9391f.tar.bz2
aports-e944709cd8381af07e711986f73d02e3e1e9391f.tar.xz
main/gamin: rebuild against pythong2.7 and split py- package
Diffstat (limited to 'main/gamin')
-rw-r--r--main/gamin/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
index bf5b3bca2..3e0647d8e 100644
--- a/main/gamin/APKBUILD
+++ b/main/gamin/APKBUILD
@@ -1,14 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gamin
pkgver=0.1.10
-pkgrel=5
+pkgrel=6
pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
url="http://www.gnome.org/~veillard/gamin"
arch="all"
license="GPL"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev py-$pkgname:py"
depends=
-makedepends="pkgconfig glib-dev"
+makedepends="pkgconfig glib-dev python-dev"
source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz"
build ()
@@ -31,4 +31,10 @@ package() {
make DESTDIR="$pkgdir" install
}
+py() {
+ pkgdesc="Python bindings for the gamin library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz"