summaryrefslogtreecommitdiffstats
path: root/main/gdb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-23 12:23:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-23 12:23:50 +0000
commit1d773a09f5f32db25ea082402c5283cf622d0da8 (patch)
tree70f6cd05997a057a28dcf157e1bafc3060f32ad5 /main/gdb
parentfa3b84db15d2c45570decc5e9335492b93cca0df (diff)
downloadaports-1d773a09f5f32db25ea082402c5283cf622d0da8.tar.bz2
aports-1d773a09f5f32db25ea082402c5283cf622d0da8.tar.xz
main/gdb: upgrade to 7.4
Diffstat (limited to 'main/gdb')
-rw-r--r--main/gdb/05_all_readline-headers.patch42
-rw-r--r--main/gdb/APKBUILD12
2 files changed, 49 insertions, 5 deletions
diff --git a/main/gdb/05_all_readline-headers.patch b/main/gdb/05_all_readline-headers.patch
new file mode 100644
index 000000000..e65adf6e6
--- /dev/null
+++ b/main/gdb/05_all_readline-headers.patch
@@ -0,0 +1,42 @@
+--- a/readline/complete.c
++++ b/readline/complete.c
+@@ -25,6 +25,11 @@
+ # include <config.h>
+ #endif
+
++#ifdef HAVE_WCHAR_H /* wcwidth() */
++# define _GNU_SOURCE
++# include <wchar.h>
++#endif
++
+ #include <sys/types.h>
+ #include <fcntl.h>
+ #if defined (HAVE_SYS_FILE_H)
+--- a/readline/display.c
++++ b/readline/display.c
+@@ -25,6 +25,11 @@
+ # include <config.h>
+ #endif
+
++#ifdef HAVE_WCHAR_H /* wcwidth() */
++# define _GNU_SOURCE
++# include <wchar.h>
++#endif
++
+ #include <sys/types.h>
+
+ #if defined (HAVE_UNISTD_H)
+--- a/readline/mbutil.c
++++ b/readline/mbutil.c
+@@ -25,6 +25,11 @@
+ # include <config.h>
+ #endif
+
++#ifdef HAVE_WCHAR_H /* wcwidth() */
++# define _GNU_SOURCE
++# include <wchar.h>
++#endif
++
+ #include <sys/types.h>
+ #include <fcntl.h>
+ #include "posixjmp.h"
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index e488e4784..bef983c8b 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,17 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
-pkgver=7.3.1
+pkgver=7.4
pkgrel=0
pkgdesc="The GNU Debugger"
url="http://sources.redhat.com/gdb/"
arch="all"
license="GPL3"
depends=
-makedepends="ncurses-dev expat-dev"
+makedepends="ncurses-dev expat-dev texinfo"
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
+ 05_all_readline-headers.patch"
# patches were found here:
-# http://distfiles.gentoo.org/distfiles/gdb-7.2-patches-1.tar.xz
+# http://distfiles.gentoo.org/distfiles/gdb-7.4-patches-1.tar.xz
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
@@ -45,4 +46,5 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-md5sums="b89a5fac359c618dda97b88645ceab47 gdb-7.3.1.tar.bz2"
+md5sums="95a9a8305fed4d30a30a6dc28ff9d060 gdb-7.4.tar.bz2
+701b030be4c141eab6409d37f5afa11b 05_all_readline-headers.patch"