summaryrefslogtreecommitdiffstats
path: root/main/gdb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-02 19:42:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-02 19:42:41 +0000
commit360f4d9b8cec176e6dfe9753b04864e7d52fe649 (patch)
tree8465814ef0c391746fe3f9b54258ee5a301f9194 /main/gdb
parent785681886734070a12dafa56caac04234d73d223 (diff)
downloadaports-360f4d9b8cec176e6dfe9753b04864e7d52fe649.tar.bz2
aports-360f4d9b8cec176e6dfe9753b04864e7d52fe649.tar.xz
main/gdb: upgrade to 7.3
Diffstat (limited to 'main/gdb')
-rw-r--r--main/gdb/80_all_gdb-6.5-dwarf-stack-overflow.patch54
-rw-r--r--main/gdb/APKBUILD11
2 files changed, 4 insertions, 61 deletions
diff --git a/main/gdb/80_all_gdb-6.5-dwarf-stack-overflow.patch b/main/gdb/80_all_gdb-6.5-dwarf-stack-overflow.patch
deleted file mode 100644
index 2c3c2cbae..000000000
--- a/main/gdb/80_all_gdb-6.5-dwarf-stack-overflow.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-http://bugs.gentoo.org/144833
-
-for gdb/ChangeLog:
-2006-08-22 Will Drewry <wad@google.com>
- Tavis Ormandy <taviso@google.com>
-
- * dwarf2read.c (decode_locdesc): Enforce location description stack
- boundaries.
- * dwarfread.c (locval): Likewise.
-
-2007-10-15 Jan Kratochvil <jan.kratochvil@redhat.com>
-
- Port to GDB-6.7.
-
-Index: gdb-6.7/gdb/dwarf2read.c
-===================================================================
---- gdb-6.7.orig/gdb/dwarf2read.c 2007-10-15 00:08:30.000000000 +0200
-+++ gdb-6.7/gdb/dwarf2read.c 2007-10-15 21:42:43.000000000 +0200
-@@ -9070,8 +9070,7 @@ dwarf2_fundamental_type (struct objfile
- callers will only want a very basic result and this can become a
- complaint.
-
-- Note that stack[0] is unused except as a default error return.
-- Note that stack overflow is not yet handled. */
-+ Note that stack[0] is unused except as a default error return. */
-
- static CORE_ADDR
- decode_locdesc (struct dwarf_block *blk, struct dwarf2_cu *cu)
-@@ -9088,7 +9087,7 @@ decode_locdesc (struct dwarf_block *blk,
-
- i = 0;
- stacki = 0;
-- stack[stacki] = 0;
-+ stack[++stacki] = 0;
-
- while (i < size)
- {
-@@ -9270,6 +9269,16 @@ decode_locdesc (struct dwarf_block *blk,
- dwarf_stack_op_name (op));
- return (stack[stacki]);
- }
-+ /* Enforce maximum stack depth of size-1 to avoid ++stacki writing
-+ outside of the allocated space. Also enforce minimum > 0.
-+ -- wad@google.com 14 Aug 2006 */
-+ if (stacki >= sizeof (stack) / sizeof (*stack) - 1)
-+ internal_error (__FILE__, __LINE__,
-+ _("location description stack too deep: %d"),
-+ stacki);
-+ if (stacki <= 0)
-+ internal_error (__FILE__, __LINE__,
-+ _("location description stack too shallow"));
- }
- return (stack[stacki]);
- }
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index b53a2b13e..b6b8e7793 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
-pkgver=7.2
-pkgrel=1
+pkgver=7.3
+pkgrel=0
pkgdesc="The GNU Debugger"
url="http://sources.redhat.com/gdb/"
arch="all"
@@ -9,9 +9,7 @@ license="GPL3"
depends=
makedepends="ncurses-dev expat-dev"
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
- 80_all_gdb-6.5-dwarf-stack-overflow.patch
- "
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2"
# patches were found here:
# http://distfiles.gentoo.org/distfiles/gdb-7.2-patches-1.tar.xz
_builddir="$srcdir"/$pkgname-$pkgver
@@ -47,5 +45,4 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-md5sums="64260e6c56979ee750a01055f16091a5 gdb-7.2.tar.bz2
-eb81ee111ba23682d4257dad50e01de0 80_all_gdb-6.5-dwarf-stack-overflow.patch"
+md5sums="485022b8df7ba2221f217e128f479fe7 gdb-7.3.tar.bz2"