summaryrefslogtreecommitdiffstats
path: root/main/gettext
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-21 11:13:28 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-21 11:14:43 -0500
commitf17d07341e5c1d9f3cdbad12e03015562e2a7b59 (patch)
treef0ee3d1d03fdbef83a0afcf76fae7fd015f07909 /main/gettext
parent20be753418a99434126dac039d7df06bf1c3d8ff (diff)
downloadaports-f17d07341e5c1d9f3cdbad12e03015562e2a7b59.tar.bz2
aports-f17d07341e5c1d9f3cdbad12e03015562e2a7b59.tar.xz
main/gettext: split out libintl
Diffstat (limited to 'main/gettext')
-rw-r--r--main/gettext/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/gettext/APKBUILD b/main/gettext/APKBUILD
index 395f8e429..161aa8759 100644
--- a/main/gettext/APKBUILD
+++ b/main/gettext/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gettext
pkgver=0.18.1.1
-pkgrel=4
+pkgrel=5
pkgdesc="GNU locale utilities"
url="http://www.gnu.org/software/gettext/gettext.html"
arch="all"
@@ -12,7 +12,7 @@ makedepends="$depends_dev bash"
source="ftp://ftp.mirror.nl/pub/mirror/gnu/gettext/gettext-$pkgver.tar.gz
gettext-uclibc.patch
"
-subpackages="$pkgname-doc $pkgname-dev"
+subpackages="$pkgname-doc $pkgname-dev libintl"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -43,5 +43,12 @@ package() {
make -j1 DESTDIR="$pkgdir/" install
}
+libintl() {
+ replaces="gettext"
+ mkdir -p "$subpkgdir"/usr/lib
+
+ mv "$pkgdir"/usr/lib/libintl.so.* "$subpkgdir"/usr/lib
+}
+
md5sums="3dd55b952826d2b32f51308f2f91aa89 gettext-0.18.1.1.tar.gz
cbf6444e7c8ad3aa70b2b80f8fcb6016 gettext-uclibc.patch"