summaryrefslogtreecommitdiffstats
path: root/main/gnokii
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-29 11:04:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-29 11:04:17 +0000
commitee526480176789d879292f47c5f35fccdccfde43 (patch)
treeafd11437678909bd2a4945e8cc81a8b55464cafc /main/gnokii
parent8bef45957978919a195778b1eeeb6191c8a58455 (diff)
downloadaports-ee526480176789d879292f47c5f35fccdccfde43.tar.bz2
aports-ee526480176789d879292f47c5f35fccdccfde43.tar.xz
main/gnokii: moved from testing
Diffstat (limited to 'main/gnokii')
-rw-r--r--main/gnokii/APKBUILD83
-rw-r--r--main/gnokii/gnokii.patch12
2 files changed, 95 insertions, 0 deletions
diff --git a/main/gnokii/APKBUILD b/main/gnokii/APKBUILD
new file mode 100644
index 000000000..8691b7a13
--- /dev/null
+++ b/main/gnokii/APKBUILD
@@ -0,0 +1,83 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnokii
+pkgver=0.6.30
+pkgrel=3
+pkgdesc="Tools and user space driver for use with mobile phones"
+url="http://www.gnokii.org/"
+arch="all"
+license="GPL"
+depends=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs xgnokii $pkgname-smsd
+ $pkgname-smsd-pgsql:pgsql $pkgname-smsd-mysql:mysql
+ $pkgname-smsd-sqlite:sqlite"
+
+makedepends="gtk+-dev mysql-dev intltool libusb-compat-dev libxpm-dev
+ bluez-dev libical-dev postgresql-dev sqlite-dev"
+source="http://www.gnokii.org/download/gnokii/gnokii-$pkgver.tar.bz2
+ gnokii.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ sed -i 's|cellphone|phone|' xgnokii/xgnokii.desktop.in
+ patch -Np1 -i "$srcdir/gnokii.patch"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-security \
+ --disable-unix98test \
+ --disable-phonet \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la
+}
+
+libs() {
+ pkgdesc="gnokii shared libraries"
+ replaces="libgnokii"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgnokii.so.* "$subpkgdir"/usr/lib/
+}
+
+xgnokii() {
+ pkgdesk="Gtk+ gnokii application"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/xgnokii "$subpkgdir"/usr/bin/
+}
+
+smsd() {
+ pkgdesc="SMS Daemon for mobile phones"
+ mkdir -p "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/bin/smsd "$subpkgdir"/usr/bin/
+}
+
+pgsql() {
+ pkgdesc="SMSD plugin for PostgreSQL storage backend"
+ depends="gnokii-smsd"
+ mkdir -p "$subpkgdir"/usr/lib/smsd
+ mv "$pkgdir"/usr/lib/smsd/*pq.so "$subpkgdir"/usr/lib/smsd/
+}
+
+mysql() {
+ pkgdesc="SMSD plugin for MySQL storage backend"
+ depends="gnokii-smsd"
+ mkdir -p "$subpkgdir"/usr/lib/smsd
+ mv "$pkgdir"/usr/lib/smsd/*mysql.so "$subpkgdir"/usr/lib/smsd/
+}
+
+sqlite() {
+ pkgdesc="SMSD plugin for SQLite storage backend"
+ depends="gnokii-smsd"
+ mkdir -p "$subpkgdir"/usr/lib/smsd
+ mv "$pkgdir"/usr/lib/smsd/*sqlite*.so "$subpkgdir"/usr/lib/smsd/
+}
+md5sums="c90137d403febbc16712d64f0eb196de gnokii-0.6.30.tar.bz2
+4d764727686ee34bc73489c8b1321c82 gnokii.patch"
diff --git a/main/gnokii/gnokii.patch b/main/gnokii/gnokii.patch
new file mode 100644
index 000000000..e64d81aa1
--- /dev/null
+++ b/main/gnokii/gnokii.patch
@@ -0,0 +1,12 @@
+diff -ur gnokii-0.6.7-old/Docs/sample/gnokiirc gnokii-0.6.7/Docs/sample/gnokiirc
+--- gnokii-0.6.7-old/Docs/sample/gnokiirc 2005-05-16 20:55:13.000000000 +0200
++++ gnokii-0.6.7/Docs/sample/gnokiirc 2005-06-03 10:49:42.000000000 +0200
+@@ -112,7 +112,7 @@
+ # permissions 4750, owned by root, group gnokii. Ensure you
+ # are in the gnokii group and that the group exists...
+ [gnokiid]
+-bindir = /usr/local/sbin/
++bindir = /usr/sbin/
+
+ # Any entries in the following two sections will be set as environment
+ # variables when running the scripts.