summaryrefslogtreecommitdiffstats
path: root/main/gnome-bluetooth
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:08:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:08:40 +0000
commit60541cd4bd75fc52d11f2f2fb5f1002d986ea938 (patch)
tree28c942a8e1d3c641396ecc1f2abee936213e22a5 /main/gnome-bluetooth
parent60daa581600dd04ce264c6901280eef020e13c0a (diff)
downloadaports-60541cd4bd75fc52d11f2f2fb5f1002d986ea938.tar.bz2
aports-60541cd4bd75fc52d11f2f2fb5f1002d986ea938.tar.xz
main/gnome-bluetooth: rebuild against libnotify-0.7
Diffstat (limited to 'main/gnome-bluetooth')
-rw-r--r--main/gnome-bluetooth/APKBUILD9
-rw-r--r--main/gnome-bluetooth/libnotify-0.7.patch11
2 files changed, 17 insertions, 3 deletions
diff --git a/main/gnome-bluetooth/APKBUILD b/main/gnome-bluetooth/APKBUILD
index 72e3f960b..6aa0b5b4d 100644
--- a/main/gnome-bluetooth/APKBUILD
+++ b/main/gnome-bluetooth/APKBUILD
@@ -1,18 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnome-bluetooth
pkgver=2.32.0
-pkgrel=2
+pkgrel=3
pkgdesc="The GNOME Bluetooth Subsystem"
url="http://live.gnome.org/GnomeBluetooth"
arch="all"
license="GPL LGPL"
depends="hicolor-icon-theme obexd-client obex-data-server"
-makedepends="intltool py-gtk gobject-introspection-dev libunique-dev libnotify-dev
- libxi-dev libxslt py-libxml2 gnome-doc-utils"
+makedepends="intltool py-gtk gobject-introspection-dev libunique-dev
+ libnotify-dev libxi-dev libxslt py-libxml2 gnome-doc-utils
+ dbus-glib-dev gtk+2.0-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.bz2
nogeoclue.patch
+ libnotify-0.7.patch
61-gnome-bluetooth-rfkill.rules"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -53,4 +55,5 @@ package() {
md5sums="f129686fe46c4c98eb70a0cc85d59cae gnome-bluetooth-2.32.0.tar.bz2
5ed6f59d02b45573a08155fca8f0d300 nogeoclue.patch
+1f6db609b5c2d6cd0076cd63b9c60afd libnotify-0.7.patch
9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules"
diff --git a/main/gnome-bluetooth/libnotify-0.7.patch b/main/gnome-bluetooth/libnotify-0.7.patch
new file mode 100644
index 000000000..5265e460e
--- /dev/null
+++ b/main/gnome-bluetooth/libnotify-0.7.patch
@@ -0,0 +1,11 @@
+--- ./applet/notify.c.orig
++++ ./applet/notify.c
+@@ -71,7 +71,7 @@
+ notify_notification_close(notify, NULL);
+ }
+
+- notify = notify_notification_new(summary, message, icon_name, NULL);
++ notify = notify_notification_new(summary, message, icon_name);
+
+ notify_notification_set_timeout(notify, timeout);
+