summaryrefslogtreecommitdiffstats
path: root/main/gnome-bluetooth
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-07 05:58:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-07 05:58:52 +0000
commita5a583e7d11705cb580c08466b2d476bca718bc1 (patch)
treed6c1dbccf9ffb33833b32c107e58d434ba5e2c50 /main/gnome-bluetooth
parentbeb1b1720862c18461a3488b1c15211df9c9ce14 (diff)
downloadaports-a5a583e7d11705cb580c08466b2d476bca718bc1.tar.bz2
aports-a5a583e7d11705cb580c08466b2d476bca718bc1.tar.xz
main/gnome-bluetooth(and dependencies): moved from testing
Diffstat (limited to 'main/gnome-bluetooth')
-rw-r--r--main/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules11
-rw-r--r--main/gnome-bluetooth/APKBUILD55
-rw-r--r--main/gnome-bluetooth/nogeoclue.patch138
3 files changed, 204 insertions, 0 deletions
diff --git a/main/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules b/main/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules
new file mode 100644
index 000000000..a76c1e73c
--- /dev/null
+++ b/main/gnome-bluetooth/61-gnome-bluetooth-rfkill.rules
@@ -0,0 +1,11 @@
+# Get access to /dev/rfkill for users
+# See https://bugzilla.redhat.com/show_bug.cgi?id=514798
+#
+# Updated for udev >= 154
+# http://bugs.debian.org/582188
+# https://bugzilla.redhat.com/show_bug.cgi?id=588660
+
+ENV{ACL_MANAGE}=="0", GOTO="gnome_bluetooth_end"
+ACTION!="add|change", GOTO="gnome_bluetooth_end"
+KERNEL=="rfkill", TAG+="udev-acl"
+LABEL="gnome_bluetooth_end"
diff --git a/main/gnome-bluetooth/APKBUILD b/main/gnome-bluetooth/APKBUILD
new file mode 100644
index 000000000..b8b78abb4
--- /dev/null
+++ b/main/gnome-bluetooth/APKBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-bluetooth
+pkgver=2.32.0
+pkgrel=1
+pkgdesc="The GNOME Bluetooth Subsystem"
+url="http://live.gnome.org/GnomeBluetooth"
+arch="all"
+license="GPL LGPL"
+depends="hicolor-icon-theme obexd-client obex-data-server"
+makedepends="intltool py-gtk gobject-introspection libunique-dev libnotify-dev
+ libxi-dev libxslt py-libxml2 gnome-doc-utils"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-bluetooth/${pkgver%.*}/gnome-bluetooth-$pkgver.tar.bz2
+ nogeoclue.patch
+ 61-gnome-bluetooth-rfkill.rules"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-nautilus-sendto \
+ --disable-schemas-compile \
+ --disable-introspection \
+ --disable-scrollkeeper \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
+ "$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
+}
+
+md5sums="f129686fe46c4c98eb70a0cc85d59cae gnome-bluetooth-2.32.0.tar.bz2
+5ed6f59d02b45573a08155fca8f0d300 nogeoclue.patch
+9fb6c8dcb5a3de3a953bf2ef42063e6e 61-gnome-bluetooth-rfkill.rules"
diff --git a/main/gnome-bluetooth/nogeoclue.patch b/main/gnome-bluetooth/nogeoclue.patch
new file mode 100644
index 000000000..2892bee0c
--- /dev/null
+++ b/main/gnome-bluetooth/nogeoclue.patch
@@ -0,0 +1,138 @@
+--- gnome-bluetooth-2.32.0.orig/configure
++++ gnome-bluetooth-2.32.0/configure
+@@ -638,8 +638,6 @@
+ MOBLIN_CFLAGS
+ PLUGINS_LIBS
+ PLUGINS_CFLAGS
+-GEOCLUE_LIBS
+-GEOCLUE_CFLAGS
+ COMMON_LIBS
+ COMMON_CFLAGS
+ LIBGNOMEBT_LIBS
+@@ -899,8 +897,6 @@
+ LIBGNOMEBT_LIBS
+ COMMON_CFLAGS
+ COMMON_LIBS
+-GEOCLUE_CFLAGS
+-GEOCLUE_LIBS
+ PLUGINS_CFLAGS
+ PLUGINS_LIBS
+ MOBLIN_CFLAGS
+@@ -13662,106 +13658,6 @@
+
+ fi
+
+-
+-pkg_failed=no
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GEOCLUE" >&5
+-$as_echo_n "checking for GEOCLUE... " >&6; }
+-
+-if test -n "$GEOCLUE_CFLAGS"; then
+- pkg_cv_GEOCLUE_CFLAGS="$GEOCLUE_CFLAGS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
+- dbus-glib-1\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gconf-2.0
+- dbus-glib-1") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_GEOCLUE_CFLAGS=`$PKG_CONFIG --cflags "gconf-2.0
+- dbus-glib-1" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-if test -n "$GEOCLUE_LIBS"; then
+- pkg_cv_GEOCLUE_LIBS="$GEOCLUE_LIBS"
+- elif test -n "$PKG_CONFIG"; then
+- if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
+- dbus-glib-1\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "gconf-2.0
+- dbus-glib-1") 2>&5
+- ac_status=$?
+- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+- test $ac_status = 0; }; then
+- pkg_cv_GEOCLUE_LIBS=`$PKG_CONFIG --libs "gconf-2.0
+- dbus-glib-1" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gconf-2.0
+- dbus-glib-1" 2>&1`
+- else
+- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --print-errors "gconf-2.0
+- dbus-glib-1" 2>&1`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$GEOCLUE_PKG_ERRORS" >&5
+-
+- as_fn_error $? "Package requirements (gconf-2.0
+- dbus-glib-1) were not met:
+-
+-$GEOCLUE_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables GEOCLUE_CFLAGS
+-and GEOCLUE_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details." "$LINENO" 5
+-
+-elif test $pkg_failed = untried; then
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+-$as_echo "no" >&6; }
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
+-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
+-as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables GEOCLUE_CFLAGS
+-and GEOCLUE_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details" "$LINENO" 5; }
+-
+-else
+- GEOCLUE_CFLAGS=$pkg_cv_GEOCLUE_CFLAGS
+- GEOCLUE_LIBS=$pkg_cv_GEOCLUE_LIBS
+- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+-$as_echo "yes" >&6; }
+-
+-fi
+
+
+ pkg_failed=no
+--- gnome-bluetooth-2.32.0.orig/lib/Makefile.in
++++ gnome-bluetooth-2.32.0/lib/Makefile.in
+@@ -383,7 +383,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-SUBDIRS = plugins
++SUBDIRS =
+ EXTRA_DIST = $(am__append_2) marshal.list bluetooth-client.xml \
+ bluetooth-agent.xml obex-agent.xml gnome-bluetooth.symbols
+ BUILT_GIRSOURCES = $(am__append_1)