summaryrefslogtreecommitdiffstats
path: root/main/hunspell
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-04 08:04:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-04 08:04:51 +0000
commitbf1b6687fd45bdbf4ae20da6f1725ba2ed913e94 (patch)
treece78bfa9eafda6645b34cea47d0d0c1b0f3b0f28 /main/hunspell
parent8dc6852037ea95173a19db63204076153cc5c905 (diff)
downloadaports-bf1b6687fd45bdbf4ae20da6f1725ba2ed913e94.tar.bz2
aports-bf1b6687fd45bdbf4ae20da6f1725ba2ed913e94.tar.xz
main/hunspell: dont use uclibc++
Diffstat (limited to 'main/hunspell')
-rw-r--r--main/hunspell/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/main/hunspell/APKBUILD b/main/hunspell/APKBUILD
index 6883855ae..baf7876c2 100644
--- a/main/hunspell/APKBUILD
+++ b/main/hunspell/APKBUILD
@@ -6,17 +6,19 @@ pkgdesc="Spell checker and morphological analyzer library and program"
url="http://hunspell.sourceforge.net/"
license="GPL LGPL MPL"
subpackages="$pkgname-dev $pkgname-doc"
-depends="libgcc uclibc++"
-makedepends="uclibc++-dev"
+depends=
+makedepends=
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
build ()
{
cd "$srcdir/hunspell-$pkgver"
- export CXX="${CXX_UC:-g++-uc}"
-
./configure --prefix=/usr --disable-static || return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir/hunspell-$pkgver"
make DESTDIR="$pkgdir" install || return 1
rm -rf "$pkgdir"/usr/share/locale/locale.alias
}