summaryrefslogtreecommitdiffstats
path: root/main/icedtea-web
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-07 08:57:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-07 08:58:15 +0000
commit1e7296f571ac31c7c6492fb62c3e9ac748902819 (patch)
treee7bed1001302b5d6cd34050403201770d5f7556e /main/icedtea-web
parent084579fbf40e7e1a0aa6fb623769e28a967a55ad (diff)
downloadaports-1e7296f571ac31c7c6492fb62c3e9ac748902819.tar.bz2
aports-1e7296f571ac31c7c6492fb62c3e9ac748902819.tar.xz
main/icedtea-web: upgrade to 1.1.5
Diffstat (limited to 'main/icedtea-web')
-rw-r--r--main/icedtea-web/APKBUILD10
-rw-r--r--main/icedtea-web/const-char-np_getmimedescription.patch11
2 files changed, 3 insertions, 18 deletions
diff --git a/main/icedtea-web/APKBUILD b/main/icedtea-web/APKBUILD
index 84afcb1a2..2073af69f 100644
--- a/main/icedtea-web/APKBUILD
+++ b/main/icedtea-web/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=icedtea-web
-pkgver=1.1.4
+pkgver=1.1.5
pkgrel=0
pkgdesc="web integration packages for icedtea"
url="http://icedtea.classpath.org/wiki/IcedTea-Web"
@@ -13,11 +13,8 @@ makedepends="tar zip $depends_dev"
install=""
subpackages="$pkgname-mozilla $pkgname-doc"
source="http://icedtea.classpath.org/download/source/icedtea-web-$pkgver.tar.gz
- const-char-np_getmimedescription.patch
"
-CPU=`uname -m | sed -e 's/i.86/i386/g' -e 's/x86_64/amd64/g'`
-
_builddir="$srcdir"/icedtea-web-$pkgver
prepare() {
local i
@@ -45,7 +42,7 @@ build() {
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install || return 1
}
mozilla() {
@@ -58,5 +55,4 @@ mozilla() {
return 0
}
-md5sums="1ed24b7e58da26471187dfae80b020b6 icedtea-web-1.1.4.tar.gz
-61a5afc7cbb205bc1cae624354266d68 const-char-np_getmimedescription.patch"
+md5sums="9cd76aa2edd6c0bc5c137df0b71347da icedtea-web-1.1.5.tar.gz"
diff --git a/main/icedtea-web/const-char-np_getmimedescription.patch b/main/icedtea-web/const-char-np_getmimedescription.patch
deleted file mode 100644
index 0194db169..000000000
--- a/main/icedtea-web/const-char-np_getmimedescription.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./plugin/icedteanp/IcedTeaNPPlugin.cc.orig
-+++ ./plugin/icedteanp/IcedTeaNPPlugin.cc
-@@ -2262,7 +2262,7 @@
-
- // Returns a string describing the MIME type that this plugin
- // handles.
--char*
-+const char*
- NP_GetMIMEDescription ()
- {
- PLUGIN_DEBUG ("NP_GetMIMEDescription\n");