summaryrefslogtreecommitdiffstats
path: root/main/iptables
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 09:14:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-23 09:14:16 +0000
commit1feb744b54d43e638a5a2c6a4a082729a441f454 (patch)
treebb3296f300a2601aab34259d8ac2617d9eff2857 /main/iptables
parente981a6e5df88d8522dc5f47571f47ba1dd9b741b (diff)
downloadaports-1feb744b54d43e638a5a2c6a4a082729a441f454.tar.bz2
aports-1feb744b54d43e638a5a2c6a4a082729a441f454.tar.xz
main/iptables: fix provides -> provide in init.d
Diffstat (limited to 'main/iptables')
-rw-r--r--main/iptables/APKBUILD6
-rw-r--r--main/iptables/iptables.initd2
2 files changed, 5 insertions, 3 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 360dbd483..62913d1cf 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,7 +2,7 @@
pkgname=iptables
pkgver=1.4.12.2
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.iptables.org/"
arch="all"
@@ -25,6 +25,8 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ sed -i -e '/if_packet/i#define __aligned_u64 __u64 __attribute__((aligned(8)))' \
+ extensions/libxt_pkttype.c || return 1
}
build() {
@@ -77,6 +79,6 @@ ip6tables() {
md5sums="212112389c7f10c72efb31a4ed193a4c iptables-1.4.12.2.tar.bz2
ec3e80a1b0ea3e13e4e60824b7ebd1b9 iptables-1.4.2-include-in.patch
-375c4431c6c7a67da28ef9c470fc7e47 iptables.initd
+d67d7e544c8af8cff63e8c89dbc96eb5 iptables.initd
2ae5c23689c65ed7e827802c47acd426 iptables.confd
91933090bd9d493c91dcffc0221def61 ip6tables.confd"
diff --git a/main/iptables/iptables.initd b/main/iptables/iptables.initd
index 6054af6e6..f7a601563 100644
--- a/main/iptables/iptables.initd
+++ b/main/iptables/iptables.initd
@@ -22,7 +22,7 @@ esac
depend() {
before net
use logger
- provides firewall
+ provide firewall
}
set_table_policy() {