summaryrefslogtreecommitdiffstats
path: root/main/iptables
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:29:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:48:15 +0000
commit4b33a80ba058c8f3513aa3882d262502a722e24e (patch)
tree719ee95494a1a74dea17842c4178b56875401b85 /main/iptables
parent0e9d349fbd920a956eea9a741ecb2e44799b93a2 (diff)
downloadaports-4b33a80ba058c8f3513aa3882d262502a722e24e.tar.bz2
aports-4b33a80ba058c8f3513aa3882d262502a722e24e.tar.xz
main/iptables: replace opts in init.d script
ref #943
Diffstat (limited to 'main/iptables')
-rw-r--r--main/iptables/APKBUILD4
-rw-r--r--[-rwxr-xr-x]main/iptables/iptables.initd12
2 files changed, 10 insertions, 6 deletions
diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 697c03322..360dbd483 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -2,7 +2,7 @@
pkgname=iptables
pkgver=1.4.12.2
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
url="http://www.iptables.org/"
arch="all"
@@ -77,6 +77,6 @@ ip6tables() {
md5sums="212112389c7f10c72efb31a4ed193a4c iptables-1.4.12.2.tar.bz2
ec3e80a1b0ea3e13e4e60824b7ebd1b9 iptables-1.4.2-include-in.patch
-2202ac150a5dfe32a8363b0ad565ee1d iptables.initd
+375c4431c6c7a67da28ef9c470fc7e47 iptables.initd
2ae5c23689c65ed7e827802c47acd426 iptables.confd
91933090bd9d493c91dcffc0221def61 ip6tables.confd"
diff --git a/main/iptables/iptables.initd b/main/iptables/iptables.initd
index e63d8ea9e..6054af6e6 100755..100644
--- a/main/iptables/iptables.initd
+++ b/main/iptables/iptables.initd
@@ -1,9 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.3.2.init,v 1.6 2007/03/12 21:49:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/files/iptables-1.4.11.init,v 1.2 2011/12/04 10:15:59 swegener Exp $
-opts="save reload panic"
+extra_commands="save panic"
+extra_started_commands="reload"
iptables_name=${SVCNAME}
if [ "${iptables_name}" != "iptables" -a "${iptables_name}" != "ip6tables" ] ; then
@@ -21,6 +22,7 @@ esac
depend() {
before net
use logger
+ provides firewall
}
set_table_policy() {
@@ -100,7 +102,9 @@ save() {
panic() {
checkkernel || return 1
- service_started ${iptables_name} && svc_stop
+ if service_started ${iptables_name}; then
+ rc-service ${iptables_name} stop
+ fi
local a
ebegin "Dropping all packets"