summaryrefslogtreecommitdiffstats
path: root/main/lame/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-08-22 15:55:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-08-22 15:55:50 +0000
commitdf681663e7f6d9dc1b00d1b1383f56c154b556ba (patch)
treef39f5f25a08bef6cf3ec59e9e6204a20391276e5 /main/lame/APKBUILD
parent5de10ff30d14ebef3b3db84b93bedc19cae3ea45 (diff)
downloadaports-df681663e7f6d9dc1b00d1b1383f56c154b556ba.tar.bz2
aports-df681663e7f6d9dc1b00d1b1383f56c154b556ba.tar.xz
main/lame: new aport
An MP3 encoder and graphical frame analyzer http://lame.sourceforge.net/
Diffstat (limited to 'main/lame/APKBUILD')
-rw-r--r--main/lame/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
new file mode 100644
index 000000000..d51994e5b
--- /dev/null
+++ b/main/lame/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lame
+pkgver=3.98.2
+pkgrel=0
+pkgdesc="An MP3 encoder and graphical frame analyzer"
+url="http://lame.sourceforge.net/"
+license="LGPL"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="nasm ncurses-dev autoconf automake libtool"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-398-2.tar.gz
+ lame-3.98.2-ffmpeg-0.5.patch"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-398-2
+
+ # link fronted shared
+ sed -i -e 's/\(^LDFLAGS.*\)-static/\1/g' frontend/Makefile.am
+
+ # fix for parallel builds
+ mkdir -p libmp3lame/i386/.libs
+
+ # Fix for ffmpeg.
+ # https://bugs.gentoo.org/show_bug.cgi?id=265830
+ patch -p1 < ../lame-3.98.2-ffmpeg-0.5.patch || return 1
+
+ aclocal && automake || return 1
+
+ ./configure --prefix=/usr \
+ --enable-nasm \
+ --disable-mp3x \
+ --enable-shared
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="719dae0ee675d0c16e0e89952930ed35 lame-398-2.tar.gz
+e84a65409b0512045edd147524ba3ad4 lame-3.98.2-ffmpeg-0.5.patch"