summaryrefslogtreecommitdiffstats
path: root/main/libnl/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-02-19 14:22:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-02-19 14:22:00 +0000
commitfe3c74dd23459bd5a35e3d14d5f999fc17bd923a (patch)
tree73119e34ac99b04195267f4bcfcc833a6a6912ad /main/libnl/APKBUILD
parent04ccd94d8d28394c087efcc17d954dcb555b7208 (diff)
downloadaports-fe3c74dd23459bd5a35e3d14d5f999fc17bd923a.tar.bz2
aports-fe3c74dd23459bd5a35e3d14d5f999fc17bd923a.tar.xz
main/libnl: moved from testing
needed by wpa_supplicant
Diffstat (limited to 'main/libnl/APKBUILD')
-rw-r--r--main/libnl/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/libnl/APKBUILD b/main/libnl/APKBUILD
new file mode 100644
index 000000000..9db755aef
--- /dev/null
+++ b/main/libnl/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libnl
+pkgver=1.1
+pkgrel=0
+pkgdesc="Library for applications dealing with netlink sockets"
+url="http://people.suug.ch/~tgr/libnl"
+license="GPL"
+depends=
+makedepends=
+subpackages="$pkgname-dev"
+source="http://distfiles.gentoo.org/distfiles/$pkgname-$pkgver.tar.gz
+ libnl-1.1-flags.patch
+ libnl-1.1-minor-leaks.patch
+ libnl-1.1-vlan-header.patch
+ libnl-1.1-glibc-2.8-ULONG_MAX.patch
+ "
+
+_builddir="$srcdir"/libnl-$pkgver
+
+prepare () {
+ cd "$_builddir"
+ for i in "$srcdir"/*.patch; do
+ [ -r "$i" ] || continue
+ msg "Applying $i"
+ patch -s -p1 -i $i || return 1
+ done
+}
+
+build () {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ae970ccd9144e132b68664f98e7ceeb1 libnl-1.1.tar.gz
+9c9072ac8b74135798e0ebcf2d90290d libnl-1.1-flags.patch
+3a42f98cfb353f2469ac3c44b7c0a027 libnl-1.1-minor-leaks.patch
+d757127e7af3bd3c82cdb51b1b09d2e0 libnl-1.1-vlan-header.patch
+9169c7eec8a2b4b2556dd26ac73c6020 libnl-1.1-glibc-2.8-ULONG_MAX.patch"