summaryrefslogtreecommitdiffstats
path: root/main/libsndfile
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-09-15 20:31:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-09-15 20:31:03 +0000
commit86f4abdf8a79f35dcc5b068dc7a4360578f41c35 (patch)
treed17546d6c45bc3005004b214351106b361215da9 /main/libsndfile
parentf14690e9e2d9fe685f8e0abbfb5e955d3756a580 (diff)
downloadaports-86f4abdf8a79f35dcc5b068dc7a4360578f41c35.tar.bz2
aports-86f4abdf8a79f35dcc5b068dc7a4360578f41c35.tar.xz
main/libsndfile: fix previous commit
The configure sript does not detect the proper CFLAGS for largefile so we need set it.
Diffstat (limited to 'main/libsndfile')
-rw-r--r--main/libsndfile/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/libsndfile/APKBUILD b/main/libsndfile/APKBUILD
index 38b34be12..19a22714d 100644
--- a/main/libsndfile/APKBUILD
+++ b/main/libsndfile/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsndfile
pkgver=1.0.25
-pkgrel=1
+pkgrel=2
pkgdesc="A C library for reading and writing files containing sampled sound"
url="http://www.mega-nerd.com/libsndfile"
arch="all"
@@ -14,9 +14,10 @@ source="http://www.mega-nerd.com/$pkgname/files/$pkgname-$pkgver.tar.gz"
build () {
cd "$srcdir"/$pkgname-$pkgver
+ ac_cv_sys_largefile_CFLAGS="-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
./configure --prefix=/usr \
--disable-sqlite \
- --enable-large \
+ --enable-largefile \
|| return 1
make || return 1
}