summaryrefslogtreecommitdiffstats
path: root/main/libtheora
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-06 08:40:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-06 08:46:54 +0000
commit5a32b80e992aab958d508279f39630c8b868d700 (patch)
treeb666a11cf85a6ef5385c169729549948af83ab8f /main/libtheora
parentec4b5e3898bf94b3b01545893ce703b2914e502d (diff)
downloadaports-5a32b80e992aab958d508279f39630c8b868d700.tar.bz2
aports-5a32b80e992aab958d508279f39630c8b868d700.tar.xz
main/libtheora: upgrade to 1.1.1
Diffstat (limited to 'main/libtheora')
-rw-r--r--main/libtheora/APKBUILD22
-rw-r--r--main/libtheora/libtheora-flags.patch14
2 files changed, 29 insertions, 7 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index e3b3999a3..1f4f1117b 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,26 +1,34 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
-pkgver=1.0
-pkgrel=1
+pkgver=1.1.1
+pkgrel=0
pkgdesc="An open video codec developed by the Xiph.org"
url="http://www.xiph.org"
license="custom"
subpackages="$pkgname-dev $pkgname-doc"
depends=
-makedepends="libvorbis-dev libogg-dev"
-source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2"
+makedepends="libvorbis-dev libogg-dev autoconf automake libtool"
+source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
+ libtheora-flags.patch"
depends_dev="libogg-dev"
-build ()
-{
+build() {
cd "$srcdir"/libtheora-$pkgver
+ patch -p1 -i ../libtheora-flags.patch || return 1
+ aclocal -I m4 && autoconf && automake || return 1
+
./configure --prefix=/usr \
--enable-shared \
--disable-static || return 1
make || return 1
+}
+
+package() {
+ cd "$srcdir"/libtheora-$pkgver
make DESTDIR="$pkgdir" install || return 1
install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
}
-md5sums="c963937053f45a7878954bed37ceb182 libtheora-1.0.tar.bz2"
+md5sums="292ab65cedd5021d6b7ddd117e07cd8e libtheora-1.1.1.tar.bz2
+7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch"
diff --git a/main/libtheora/libtheora-flags.patch b/main/libtheora/libtheora-flags.patch
new file mode 100644
index 000000000..a47cc5771
--- /dev/null
+++ b/main/libtheora/libtheora-flags.patch
@@ -0,0 +1,14 @@
+diff -ur libtheora-1.0beta2.orig/configure.ac libtheora-1.0beta2/configure.ac
+--- libtheora-1.0beta2.orig/configure.ac 2007-10-13 00:01:38.000000000 +0300
++++ libtheora-1.0beta2/configure.ac 2007-11-25 22:44:49.000000000 +0200
+@@ -102,8 +102,8 @@
+ case $host in
+ *)
+ DEBUG="-g -Wall -Wno-parentheses -DDEBUG -D__NO_MATH_INLINES"
+- CFLAGS="-Wall -Wno-parentheses -O3 -fforce-addr -fomit-frame-pointer -finline-functions -funroll-loops"
+- PROFILE="-Wall -Wno-parentheses -pg -g -O3 -fno-inline-functions -DDEBUG";;
++ CFLAGS="-Wall -Wno-parentheses"
++ PROFILE="-Wall -Wno-parentheses -pg -g -fno-inline-functions -DDEBUG";;
+ esac
+ fi
+ CFLAGS="$CFLAGS $cflags_save"