summaryrefslogtreecommitdiffstats
path: root/main/libxml2/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-30 16:00:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-30 16:00:41 +0000
commit079d11998b9a2998a4f603e238f37d3559ce673c (patch)
treee2cc284e13a5c505dc8521598d545e57f30e13bc /main/libxml2/APKBUILD
parentd4152a1f83590fbed81dbc45d7d54a8ed7ad9fc0 (diff)
downloadaports-079d11998b9a2998a4f603e238f37d3559ce673c.tar.bz2
aports-079d11998b9a2998a4f603e238f37d3559ce673c.tar.xz
main/libxml2: patch abuse of zlib API
Diffstat (limited to 'main/libxml2/APKBUILD')
-rw-r--r--main/libxml2/APKBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index e69914ed2..58514b1ea 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -2,17 +2,29 @@
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=libxml2
pkgver=2.7.6
-pkgrel=1
+pkgrel=2
pkgdesc="XML parsing library, version 2"
url="http://www.xmlsoft.org/"
license="MIT"
depends=
makedepends="zlib-dev python-dev"
subpackages="$pkgname-doc $pkgname-dev py-$pkgname:py"
-source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ largefile64.patch
+ zlib.patch"
+
+options="!strip"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ for _i in "$srcdir"/*.patch; do
+ patch -p1 -i "$_i"
+ done
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -21,16 +33,19 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make -j1 DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
}
py() {
+ cd "$_builddir"
pkgdesc="$pkgname python bindings"
install -d "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}
-md5sums="7740a8ec23878a2f50120e1faa2730f2 libxml2-2.7.6.tar.gz"
+md5sums="7740a8ec23878a2f50120e1faa2730f2 libxml2-2.7.6.tar.gz
+5ad4915665608ebfa5b89f7908467a72 largefile64.patch
+0365d5397164b8739219e56e5ca069d1 zlib.patch"