summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-27 12:03:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-27 12:03:49 +0000
commita1dfaa7bfac80018221dd2031e02b883c76d7bdb (patch)
tree49598042589a1312219f231ff3e8050a768c5ff8 /main/linux-grsec
parente3d8cfe3f08df6649c56b637cead8efe622220f1 (diff)
downloadaports-a1dfaa7bfac80018221dd2031e02b883c76d7bdb.tar.bz2
aports-a1dfaa7bfac80018221dd2031e02b883c76d7bdb.tar.xz
main/linux-grsec: fix booting soekris 4801
fix from pipacs. see http://lists.alpinelinux.org/alpine-devel/1029.html
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/sync-core.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 53620b141..2e2d3241e 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=2.6.32.19
_kernver=2.6.32
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -39,6 +39,7 @@ source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
hv-grsec.patch
fixes-for-using-make-3.82.patch
+ sync-core.patch
kernelconfig.x86
"
subpackages="$pkgname-dev linux-firmware:firmware"
@@ -175,4 +176,5 @@ b41ee19f13498fb25992fd60cd1126d4 r8169-fix-mdio_read-and-update-mdio_write-acco
a1bcf76870b63a4a4035a8948fb758e2 x86-setup-When-restoring-the-screen-update-boot_params-screen_info.patch
bf14850a0036d14bc6177adbdec23a17 hv-grsec.patch
3177c2a571b4827c1140d227e6ed06d0 fixes-for-using-make-3.82.patch
+4bafb5d3b45beb375791a90dfc6c8263 sync-core.patch
ca9c63def600e77ca3cb7e822c239083 kernelconfig.x86"
diff --git a/main/linux-grsec/sync-core.patch b/main/linux-grsec/sync-core.patch
new file mode 100644
index 000000000..792398304
--- /dev/null
+++ b/main/linux-grsec/sync-core.patch
@@ -0,0 +1,13 @@
+--- ./arch/x86/kernel/alternative.c.orig
++++ ./arch/x86/kernel/alternative.c
+@@ -500,9 +500,9 @@
+
+ pax_open_kernel();
+ memcpy(ktla_ktva(addr), opcode, len);
++ sync_core();
+ pax_close_kernel();
+
+- sync_core();
+ local_irq_restore(flags);
+ /* Could also do a CLFLUSH here to speed up CPU recovery; but
+ that causes hangs on some VIA CPUs. */