summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-03 13:58:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-03 13:59:57 +0000
commitc01bf3f5ef990022b0c8accacdd4e5dba0eec4fb (patch)
tree32154c7111bb97341c02f8c65fe2ca8aa3d368b1 /main/linux-grsec
parent5b3c6ef0a3f748f04d6be9e12123bb4339f755ec (diff)
downloadaports-c01bf3f5ef990022b0c8accacdd4e5dba0eec4fb.tar.bz2
aports-c01bf3f5ef990022b0c8accacdd4e5dba0eec4fb.tar.xz
main/linux-grsec: upgrade to 3.4.10 kernel
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD8
-rw-r--r--main/linux-grsec/grsecurity-2.9.1-3.4.10-1.patch (renamed from main/linux-grsec/grsecurity-2.9.1-3.4.9-1.patch)12
2 files changed, 10 insertions, 10 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index c0d2ac93f..1fbb55650 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -2,7 +2,7 @@
_flavor=grsec
pkgname=linux-${_flavor}
-pkgver=3.4.9
+pkgver=3.4.10
_kernver=3.4
pkgrel=0
pkgdesc="Linux kernel with grsecurity"
@@ -14,7 +14,7 @@ _config=${config:-kernelconfig.${CARCH}}
install=
source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$_kernver.tar.xz
http://ftp.kernel.org/pub/linux/kernel/v3.x/patch-$pkgver.xz
- grsecurity-2.9.1-3.4.9-1.patch
+ grsecurity-2.9.1-$pkgver-1.patch
0004-arp-flush-arp-cache-on-device-change.patch
0001-Revert-ipv4-Don-t-use-the-cached-pmtu-informations-f.patch
@@ -140,8 +140,8 @@ dev() {
}
md5sums="967f72983655e2479f951195953e8480 linux-3.4.tar.xz
-ffd1d2010b97fe45a62c9ce856ca224f patch-3.4.9.xz
-eb144eed1f834e81862d7457baad686b grsecurity-2.9.1-3.4.9-1.patch
+5ac016a4a5b47179a0aee0dbadbb2254 patch-3.4.10.xz
+e495e6b5cad4fbd55ba394c7bd351be7 grsecurity-2.9.1-3.4.10-1.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
cb6fcd6e966e73c87a839c4c0183f81f 0001-Revert-ipv4-Don-t-use-the-cached-pmtu-informations-f.patch
50a13359236dbd676fa355f0b4fd27ff kernelconfig.x86
diff --git a/main/linux-grsec/grsecurity-2.9.1-3.4.9-1.patch b/main/linux-grsec/grsecurity-2.9.1-3.4.10-1.patch
index b08bf8c2c..0aa2a58e8 100644
--- a/main/linux-grsec/grsecurity-2.9.1-3.4.9-1.patch
+++ b/main/linux-grsec/grsecurity-2.9.1-3.4.10-1.patch
@@ -269,7 +269,7 @@ index 88fd7f5..b318a78 100644
==============================================================
diff --git a/Makefile b/Makefile
-index 9549547..dc17992 100644
+index a1624b9..10ff8ea 100644
--- a/Makefile
+++ b/Makefile
@@ -245,8 +245,9 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
@@ -30568,7 +30568,7 @@ index 26c67a7..8d4cbcb 100644
INIT_WORK(&dev_priv->hotplug_work, i915_hotplug_work_func);
INIT_WORK(&dev_priv->error_work, i915_error_work_func);
diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
-index d4d162f..b49a04e 100644
+index 3de3d9b..7cb4130 100644
--- a/drivers/gpu/drm/i915/intel_display.c
+++ b/drivers/gpu/drm/i915/intel_display.c
@@ -2254,7 +2254,7 @@ intel_finish_fb(struct drm_framebuffer *old_fb)
@@ -30589,7 +30589,7 @@ index d4d162f..b49a04e 100644
}
static bool intel_crtc_driving_pch(struct drm_crtc *crtc)
-@@ -7284,9 +7284,8 @@ static void do_intel_finish_page_flip(struct drm_device *dev,
+@@ -7273,9 +7273,8 @@ static void do_intel_finish_page_flip(struct drm_device *dev,
obj = work->old_fb_obj;
@@ -30601,7 +30601,7 @@ index d4d162f..b49a04e 100644
wake_up(&dev_priv->pending_flip_queue);
schedule_work(&work->work);
-@@ -7582,7 +7581,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
+@@ -7571,7 +7570,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
/* Block clients from rendering to the new back buffer until
* the flip occurs and the object is no longer visible.
*/
@@ -30610,7 +30610,7 @@ index d4d162f..b49a04e 100644
ret = dev_priv->display.queue_flip(dev, crtc, fb, obj);
if (ret)
-@@ -7596,7 +7595,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
+@@ -7585,7 +7584,7 @@ static int intel_crtc_page_flip(struct drm_crtc *crtc,
return 0;
cleanup_pending:
@@ -30819,7 +30819,7 @@ index 2746402..c8dc4a4 100644
.train_set = nv50_sor_dp_train_set,
.train_adj = nv50_sor_dp_train_adj
diff --git a/drivers/gpu/drm/nouveau/nvd0_display.c b/drivers/gpu/drm/nouveau/nvd0_display.c
-index 0247250..d2f6aaf 100644
+index 8a555fb..2743fe6 100644
--- a/drivers/gpu/drm/nouveau/nvd0_display.c
+++ b/drivers/gpu/drm/nouveau/nvd0_display.c
@@ -1366,7 +1366,7 @@ nvd0_sor_dpms(struct drm_encoder *encoder, int mode)