summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-31 14:12:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-31 14:54:11 +0000
commite252523492f16fb42f0c872e7040f7fb9af891bc (patch)
tree15270e97ba3f9a28944ba32487274624aa38bb5d /main/linux-grsec
parent49548e7a898968dd7d75e7e10eb27b33cf6d21ae (diff)
downloadaports-e252523492f16fb42f0c872e7040f7fb9af891bc.tar.bz2
aports-e252523492f16fb42f0c872e7040f7fb9af891bc.tar.xz
main/linux-grsec: add support for PPS
Requested by nangel
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD6
-rw-r--r--main/linux-grsec/kernelconfig.x8614
-rw-r--r--main/linux-grsec/kernelconfig.x86_6414
3 files changed, 23 insertions, 11 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 10c951dc9..6c96b7d23 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.3.8
_kernver=3.3
-pkgrel=3
+pkgrel=4
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -144,5 +144,5 @@ e1714b5136a7f4dab1b5d2d7f98e2891 patch-3.3.8.xz
4a97aa5ad465a5d829e88c8234f75417 grsecurity-2.9-3.3.8-201206042136.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
cb6fcd6e966e73c87a839c4c0183f81f 0001-Revert-ipv4-Don-t-use-the-cached-pmtu-informations-f.patch
-0962abf0f03955adaa096218a54b950d kernelconfig.x86
-335df337d087ff345e1d4c8297d75222 kernelconfig.x86_64"
+0162c07ae4e7f0fa1befc66e2f39f5ba kernelconfig.x86
+ea617682c6140c346277186ce1f336aa kernelconfig.x86_64"
diff --git a/main/linux-grsec/kernelconfig.x86 b/main/linux-grsec/kernelconfig.x86
index 756f810bb..fb4209a9c 100644
--- a/main/linux-grsec/kernelconfig.x86
+++ b/main/linux-grsec/kernelconfig.x86
@@ -2814,19 +2814,25 @@ CONFIG_SPI_TLE62X0=m
#
# PPS support
#
-# CONFIG_PPS is not set
+CONFIG_PPS=m
+# CONFIG_PPS_DEBUG is not set
#
-# PPS generators support
+# PPS clients support
#
+# CONFIG_PPS_CLIENT_KTIMER is not set
+CONFIG_PPS_CLIENT_LDISC=m
+# CONFIG_PPS_CLIENT_PARPORT is not set
+# CONFIG_PPS_CLIENT_GPIO is not set
#
-# PTP clock support
+# PPS generators support
#
#
-# Enable Device Drivers -> PPS to see the PTP clock options.
+# PTP clock support
#
+# CONFIG_PTP_1588_CLOCK is not set
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_GPIOLIB=y
# CONFIG_DEBUG_GPIO is not set
diff --git a/main/linux-grsec/kernelconfig.x86_64 b/main/linux-grsec/kernelconfig.x86_64
index c90a67429..76557d225 100644
--- a/main/linux-grsec/kernelconfig.x86_64
+++ b/main/linux-grsec/kernelconfig.x86_64
@@ -2775,19 +2775,25 @@ CONFIG_SPI_TLE62X0=m
#
# PPS support
#
-# CONFIG_PPS is not set
+CONFIG_PPS=m
+# CONFIG_PPS_DEBUG is not set
#
-# PPS generators support
+# PPS clients support
#
+# CONFIG_PPS_CLIENT_KTIMER is not set
+CONFIG_PPS_CLIENT_LDISC=m
+# CONFIG_PPS_CLIENT_PARPORT is not set
+# CONFIG_PPS_CLIENT_GPIO is not set
#
-# PTP clock support
+# PPS generators support
#
#
-# Enable Device Drivers -> PPS to see the PTP clock options.
+# PTP clock support
#
+# CONFIG_PTP_1588_CLOCK is not set
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_GPIOLIB=y
# CONFIG_DEBUG_GPIO is not set