summaryrefslogtreecommitdiffstats
path: root/main/linux-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-10 09:58:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-10 12:07:38 +0000
commitfdae0bf0aaa004a521fafec200ab4656a239b7eb (patch)
tree231856e6313182749823ca1d6aa5fe523e19175d /main/linux-grsec
parent8056d4d2714d9155941c46fe1eef969dab94b903 (diff)
downloadaports-fdae0bf0aaa004a521fafec200ab4656a239b7eb.tar.bz2
aports-fdae0bf0aaa004a521fafec200ab4656a239b7eb.tar.xz
main/linux-grsec: fix for rx_missed on r8169 driver
Some info in this thread: http://marc.info/?l=linux-netdev&m=135763417428530&w=2
Diffstat (limited to 'main/linux-grsec')
-rw-r--r--main/linux-grsec/APKBUILD4
-rw-r--r--main/linux-grsec/r8169-num-rx-desc.patch13
2 files changed, 16 insertions, 1 deletions
diff --git a/main/linux-grsec/APKBUILD b/main/linux-grsec/APKBUILD
index 5ec5e45c5..6d100bd9d 100644
--- a/main/linux-grsec/APKBUILD
+++ b/main/linux-grsec/APKBUILD
@@ -4,7 +4,7 @@ _flavor=grsec
pkgname=linux-${_flavor}
pkgver=3.6.11
_kernver=3.6
-pkgrel=1
+pkgrel=2
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -17,6 +17,7 @@ source="http://ftp.kernel.org/pub/linux/kernel/v3.x/linux-$_kernver.tar.xz
grsecurity-2.9.1-3.6.11-unofficial-1.patch
0004-arp-flush-arp-cache-on-device-change.patch
+ r8169-num-rx-desc.patch
kernelconfig.x86
kernelconfig.x86_64
@@ -142,5 +143,6 @@ md5sums="1a1760420eac802c541a20ab51a093d1 linux-3.6.tar.xz
bd4bba74093405887d521309a74c19e9 patch-3.6.11.xz
dce5c43ac3b5d8e35e245b35e90e1837 grsecurity-2.9.1-3.6.11-unofficial-1.patch
776adeeb5272093574f8836c5037dd7d 0004-arp-flush-arp-cache-on-device-change.patch
+daf2cbb558588c49c138fe9ca2482b64 r8169-num-rx-desc.patch
373db5888708938c6b1baed6da781fcb kernelconfig.x86
190788fb10e79abce9d570d5e87ec3b4 kernelconfig.x86_64"
diff --git a/main/linux-grsec/r8169-num-rx-desc.patch b/main/linux-grsec/r8169-num-rx-desc.patch
new file mode 100644
index 000000000..c50d963ff
--- /dev/null
+++ b/main/linux-grsec/r8169-num-rx-desc.patch
@@ -0,0 +1,13 @@
+diff --git a/drivers/net/ethernet/realtek/r8169.c b/drivers/net/ethernet/realtek/r8169.c
+index 9cc0215..19e5b4d 100644
+--- a/drivers/net/ethernet/realtek/r8169.c
++++ b/drivers/net/ethernet/realtek/r8169.c
+@@ -80,7 +80,7 @@ static const int multicast_filter_limit = 32;
+ #define R8169_REGS_SIZE 256
+ #define R8169_NAPI_WEIGHT 64
+ #define NUM_TX_DESC 64 /* Number of Tx descriptor registers */
+-#define NUM_RX_DESC 256 /* Number of Rx descriptor registers */
++#define NUM_RX_DESC 512 /* Number of Rx descriptor registers */
+ #define RX_BUF_SIZE 1536 /* Rx Buffer size */
+ #define R8169_TX_RING_BYTES (NUM_TX_DESC * sizeof(struct TxDesc))
+ #define R8169_RX_RING_BYTES (NUM_RX_DESC * sizeof(struct RxDesc))