summaryrefslogtreecommitdiffstats
path: root/main/linux-vserver
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-10 19:59:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-10 19:59:59 +0000
commitc19533a6b74526420e9ea8871f61cedc7959bdb6 (patch)
tree63a89618d6c985112d5564b9184190b320d5c94e /main/linux-vserver
parentfbc502b0d2d86a1c067f25f6b1643e938fc0c924 (diff)
downloadaports-c19533a6b74526420e9ea8871f61cedc7959bdb6.tar.bz2
aports-c19533a6b74526420e9ea8871f61cedc7959bdb6.tar.xz
main/linux-vserver: fix for hyper-v drivers
Diffstat (limited to 'main/linux-vserver')
-rw-r--r--main/linux-vserver/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch38
-rw-r--r--main/linux-vserver/APKBUILD4
2 files changed, 41 insertions, 1 deletions
diff --git a/main/linux-vserver/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch b/main/linux-vserver/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
new file mode 100644
index 000000000..1133c7591
--- /dev/null
+++ b/main/linux-vserver/0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
@@ -0,0 +1,38 @@
+From 6ee51b8d69833b3cd00901999c36c59fbfde24aa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 10 Dec 2010 16:23:26 +0200
+Subject: [PATCH] Staging: hv: fix sleeping while atomic issue
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+osd_schedule_callback() is called from VmbusOnMsgDPC() which runs
+in a tasklet. Avoid possible sleeping by using GFP_ATOMIC for the
+memory allocation.
+
+Seems to fix #16701.
+
+Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=16701
+Cc: Haiyang Zhang <haiyangz@microsoft.com>
+Cc: Hank Janssen <hjanssen@microsoft.com>
+Signed-off-by: Timo Teräs <timo.teras@iki.fi>
+---
+ drivers/staging/hv/osd.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/drivers/staging/hv/osd.c b/drivers/staging/hv/osd.c
+index 8c3eb27..eb9b20d 100644
+--- a/drivers/staging/hv/osd.c
++++ b/drivers/staging/hv/osd.c
+@@ -214,7 +214,7 @@ int osd_schedule_callback(struct workqueue_struct *wq,
+ {
+ struct osd_callback_struct *cb;
+
+- cb = kmalloc(sizeof(*cb), GFP_KERNEL);
++ cb = kmalloc(sizeof(*cb), GFP_ATOMIC);
+ if (!cb) {
+ printk(KERN_ERR "unable to allocate memory in osd_schedule_callback\n");
+ return -1;
+--
+1.7.1
+
diff --git a/main/linux-vserver/APKBUILD b/main/linux-vserver/APKBUILD
index d0d8d5cb7..29373eeb1 100644
--- a/main/linux-vserver/APKBUILD
+++ b/main/linux-vserver/APKBUILD
@@ -5,7 +5,7 @@ pkgname=linux-${_flavor}
pkgver=2.6.35.9
_kernver=2.6.35
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with vserver"
url="http://linux-vserver.org/"
depends="mkinitfs linux-firmware"
@@ -15,6 +15,7 @@ _config=${config:-kernelconfig.${CARCH}}
install=
source="ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-$_kernver.tar.bz2
ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-$pkgver.bz2
+ 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
patch-2.6.35.9-vs2.3.0.36.33.diff
setlocalversion.patch
kernelconfig.x86
@@ -126,6 +127,7 @@ dev() {
md5sums="091abeb4684ce03d1d936851618687b6 linux-2.6.35.tar.bz2
eca407cf4872ad77ae23adc8242389c4 patch-2.6.35.9.bz2
+648d8b477248f233c318a3b7a961febf 0001-Staging-hv-fix-sleeping-while-atomic-issue.patch
915974abb0ad49337b91f0f487593fd2 patch-2.6.35.9-vs2.3.0.36.33.diff
8c224ba0cdf0aa572c7eb50379435be4 setlocalversion.patch
10b1e713ce4422e69e1c96ba78feb7a9 kernelconfig.x86