summaryrefslogtreecommitdiffstats
path: root/main/loudmouth/04-use-pkg-config-for-gnutls.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-20 09:52:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-20 09:54:19 +0000
commitf1e2848544e198ef0f35acb3dcfd5c7d48153b51 (patch)
tree2c7edd5fd09b1060fac2f744762134fe7e6e46f4 /main/loudmouth/04-use-pkg-config-for-gnutls.patch
parent4917c6fd5f8db34e84adeb09a992fdd490a75404 (diff)
downloadaports-f1e2848544e198ef0f35acb3dcfd5c7d48153b51.tar.bz2
aports-f1e2848544e198ef0f35acb3dcfd5c7d48153b51.tar.xz
main/loudmouth: moved from testing
and add compile fix
Diffstat (limited to 'main/loudmouth/04-use-pkg-config-for-gnutls.patch')
-rw-r--r--main/loudmouth/04-use-pkg-config-for-gnutls.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/loudmouth/04-use-pkg-config-for-gnutls.patch b/main/loudmouth/04-use-pkg-config-for-gnutls.patch
new file mode 100644
index 000000000..eecd41987
--- /dev/null
+++ b/main/loudmouth/04-use-pkg-config-for-gnutls.patch
@@ -0,0 +1,24 @@
+Description: use pkg-config to detect gnutls
+Debian: http://bugs.debian.org/529835
+Origin: http://groups.google.com/group/loudmouth-dev/browse_thread/thread/3f78255837048daf#
+
+--- a/configure.ac.orig 2009-08-16 20:29:36.000000000 +0200
++++ b/configure.ac 2009-08-16 20:30:43.000000000 +0200
+@@ -146,10 +146,12 @@ AC_ARG_WITH(openssl-libs,
+ enable_ssl=no
+ if test "x$ac_ssl" = "xgnutls"; then
+ dnl Look for GnuTLS
+- AM_PATH_LM_LIBGNUTLS($GNUTLS_REQUIRED, have_libgnutls=yes, have_libgnutls=no)
+- if test "x$have_libgnutls" = "xyes"; then
+- CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
+- LIBS="$LIBS $LIBGNUTLS_LIBS"
++ PKG_CHECK_MODULES(GNUTLS, gnutls >= $GNUTLS_REQUIRED, have_gnutls=yes, have_gnutls=no)
++ if test "x$have_gnutls" = "xyes"; then
++ AC_SUBST(ASYNCNS_CFLAGS)
++ AC_SUBST(ASYNCNS_LIBS)
++ CFLAGS="$CFLAGS $GNUTLS_CFLAGS"
++ LIBS="$LIBS $GNUTLS_LIBS"
+ AC_DEFINE(HAVE_GNUTLS, 1, [whether to use GnuTSL support.])
+ enable_ssl=GnuTLS
+ else
+