summaryrefslogtreecommitdiffstats
path: root/main/lua-llthreads
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-31 13:14:34 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-31 13:16:57 +0200
commit93a14aa8b21c339f1446d8bc4c5a73ad3d09dfd7 (patch)
tree6d1c657023ec5763517e8323dcfbf3f512989e24 /main/lua-llthreads
parentc874b524259eaee82f02c006a92b46032ae66743 (diff)
downloadaports-93a14aa8b21c339f1446d8bc4c5a73ad3d09dfd7.tar.bz2
aports-93a14aa8b21c339f1446d8bc4c5a73ad3d09dfd7.tar.xz
main/lua-llthreads: moved from testing
Diffstat (limited to 'main/lua-llthreads')
-rw-r--r--main/lua-llthreads/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/lua-llthreads/APKBUILD b/main/lua-llthreads/APKBUILD
new file mode 100644
index 000000000..b27581503
--- /dev/null
+++ b/main/lua-llthreads/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-llthreads
+pkgver=1.1
+pkgrel=0
+pkgdesc="Low-Level native threads module for Lua"
+url="https://github.com/Neopallium/lua-llthreads"
+arch="all"
+license="MIT"
+depends=""
+makedepends="wget cmake"
+install=""
+subpackages=
+source="saveas-http://github.com/Neopallium/lua-llthreads/tarball/v1.1/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Neopallium-lua-llthreads-48c39a5
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="f5c80984e7d8849ad777b42c4594da8d lua-llthreads-1.1.tar.gz"