summaryrefslogtreecommitdiffstats
path: root/main/lua-xctrl
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-04 22:58:02 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-04 22:58:02 +0100
commit98a2bb1158a766de71d61b9eb007597a10ea39d4 (patch)
tree9918dbf76cfb4ef135801b154295cea51f47b44f /main/lua-xctrl
parent4b4ad2c27321f4bddd86d4be3fddeb00e70b706c (diff)
downloadaports-98a2bb1158a766de71d61b9eb007597a10ea39d4.tar.bz2
aports-98a2bb1158a766de71d61b9eb007597a10ea39d4.tar.xz
main/lua-xctrl: fix build on eglibc
Diffstat (limited to 'main/lua-xctrl')
-rw-r--r--main/lua-xctrl/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/lua-xctrl/APKBUILD b/main/lua-xctrl/APKBUILD
index fa7bac7be..eb0176756 100644
--- a/main/lua-xctrl/APKBUILD
+++ b/main/lua-xctrl/APKBUILD
@@ -26,7 +26,7 @@ prepare() {
build() {
cd "$_builddir"
export EXTRA_CFLAGS="-fPIC"
- export EXTRA_LDFLAGS="-liconv"
+ [ "$ALPINE_LIBC" != "eglibc" ] && export EXTRA_LDFLAGS="-liconv"
make || return 1
}