summaryrefslogtreecommitdiffstats
path: root/main/mg
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-23 16:15:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-23 16:15:08 +0000
commit337cb0b026ea31673af5cb34871e976fcb4e1dfb (patch)
treed915cfaf86fbdc2111e2fd170f3e7b1a5f3fe05e /main/mg
parentd64bddab69d62921f589cb14a7b64ecc542d2ddd (diff)
downloadaports-337cb0b026ea31673af5cb34871e976fcb4e1dfb.tar.bz2
aports-337cb0b026ea31673af5cb34871e976fcb4e1dfb.tar.xz
main/mg: moved from testing
Diffstat (limited to 'main/mg')
-rw-r--r--main/mg/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/mg/APKBUILD b/main/mg/APKBUILD
new file mode 100644
index 000000000..bf4a9660a
--- /dev/null
+++ b/main/mg/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Lee Hinman <hinman@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mg
+pkgver=20090107
+pkgrel=0
+pkgdesc="mg is Micro GNU/emacs, this is a portable version of the mg maintained by the OpenBSD team."
+url="http://homepage.boetes.org/software/mg"
+license="public-domain BSD"
+depends=
+makedepends="ncurses-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://homepage.boetes.org/software/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ sed -i -e '/^CFLAGS/s/-Werror//' Makefile.in
+}
+
+build() {
+ cd "$_builddir"
+ ./configure
+ make prefix=/usr mandir=/usr/share/man || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix=/usr mandir=/usr/share/man install
+}
+
+md5sums="f25a139da44c3a2f760ffec531bd996e mg-20090107.tar.gz"