summaryrefslogtreecommitdiffstats
path: root/main/mkinitfs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-09 16:04:23 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-09 16:04:23 +0000
commit26e9e6bc1b5704b88f176ee99dd2654374691527 (patch)
tree54acedb6cd86f871f0716b83732b9a0a436a33b0 /main/mkinitfs
parent71799865c4954850b62406e0e565189da1a2ae6f (diff)
downloadaports-26e9e6bc1b5704b88f176ee99dd2654374691527.tar.bz2
aports-26e9e6bc1b5704b88f176ee99dd2654374691527.tar.xz
main/mkinitfs: fix for parsing modules.dep when it has full paths
fixes issue with initramfs not having the needed modules
Diffstat (limited to 'main/mkinitfs')
-rw-r--r--main/mkinitfs/APKBUILD15
-rw-r--r--main/mkinitfs/mod-deps.patch23
2 files changed, 36 insertions, 2 deletions
diff --git a/main/mkinitfs/APKBUILD b/main/mkinitfs/APKBUILD
index af86c94ed..426ada44b 100644
--- a/main/mkinitfs/APKBUILD
+++ b/main/mkinitfs/APKBUILD
@@ -1,15 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mkinitfs
pkgver=2.0_rc9
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to generate initramfs images for Alpine"
url=http://git.alpinelinux.org/cgit/mkinitfs
depends="busybox apk-tools>=2.0"
triggers="$pkgname.trigger:/usr/share/kernel/*"
source="http://git.alpinelinux.org/cgit/$pkgname/snapshot/$pkgname-$pkgver.tar.bz2
+ mod-deps.patch
"
license="GPL-2"
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case "$i" in
+ *.patch) patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$srcdir"/$pkgname-$pkgver
make || return 1
@@ -19,4 +29,5 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make install DESTDIR="$pkgdir" || return 1
}
-md5sums="54eb3779916b61c91f91c608dc99667a mkinitfs-2.0_rc9.tar.bz2"
+md5sums="54eb3779916b61c91f91c608dc99667a mkinitfs-2.0_rc9.tar.bz2
+ff8fd46b88690e74505f3fe31fae0aff mod-deps.patch"
diff --git a/main/mkinitfs/mod-deps.patch b/main/mkinitfs/mod-deps.patch
new file mode 100644
index 000000000..bc08d6185
--- /dev/null
+++ b/main/mkinitfs/mod-deps.patch
@@ -0,0 +1,23 @@
+commit 18f70462c7fefe7cadcc1cd618b88de565a0f717
+Author: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon Aug 9 15:56:35 2010 +0000
+
+ mkinitfs: handle the case when modules.dep has full path
+
+ we do that by simply removing the prepend string
+
+diff --git a/mkinitfs.in b/mkinitfs.in
+index c3d8354..8246d07 100755
+--- a/mkinitfs.in
++++ b/mkinitfs.in
+@@ -92,6 +92,10 @@ BEGIN {
+ modulesdep="modules.dep";
+ FS = ": ";
+ while ( (getline < modulesdep) > 0) {
++ if (substr($0,1,1) == "/") {
++ gsub(prepend, "", $1);
++ gsub(prepend, "", $2);
++ }
+ deps[$1] = $2;
+ }
+ }