summaryrefslogtreecommitdiffstats
path: root/main/mousepad
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-02-25 10:52:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-02-25 10:52:57 +0000
commitd2193e424b628c1a66bd62a83e80f5087382a4e1 (patch)
treed8c05d6ef404cc423eb9ede92d9f915175c39e58 /main/mousepad
parent4a5a7581dd128a08f20958c3550ee9d654b9a981 (diff)
downloadaports-d2193e424b628c1a66bd62a83e80f5087382a4e1.tar.bz2
aports-d2193e424b628c1a66bd62a83e80f5087382a4e1.tar.xz
main/mousepad: fix source url and use trigger
Diffstat (limited to 'main/mousepad')
-rw-r--r--main/mousepad/APKBUILD20
l---------main/mousepad/mousepad.post-deinstall1
-rw-r--r--main/mousepad/mousepad.post-install4
3 files changed, 10 insertions, 15 deletions
diff --git a/main/mousepad/APKBUILD b/main/mousepad/APKBUILD
index 2a3c9fd3a..49a34cb1b 100644
--- a/main/mousepad/APKBUILD
+++ b/main/mousepad/APKBUILD
@@ -1,17 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mousepad
pkgver=0.2.16
-pkgrel=1
+pkgrel=2
pkgdesc="Simple Text Editor for Xfce4 (based on Gedit)"
-url="http://www.xfce.org/~benny/apps.html"
+url="http://foo-projects.org/~benny/xfce/apps.html"
arch="all"
license="GPL-2"
-makedepends="pkgconfig libxfcegui4-dev intltool gettext-dev libiconv-dev
- libsm-dev e2fsprogs-dev expat-dev"
+makedepends="libxfcegui4-dev"
depends="desktop-file-utils"
-install="mousepad.post-install mousepad.post-deinstall"
-source="http://www.xfce.org/archive/xfce-4.6.0/src/$pkgname-$pkgver.tar.bz2
- $install"
+install=
+source="http://archive.xfce.org/src/apps/mousepad/${pkgver%.*}/mousepad-$pkgver.tar.bz2"
build ()
{
@@ -22,8 +20,10 @@ build ()
--localstatedir=/var \
--disable-static
make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="d98854edb76d823ac20b266fdf5a64a1 mousepad-0.2.16.tar.bz2
-5ee3bbceee9d5e58b6fd8afeba87980b mousepad.post-install
-5ee3bbceee9d5e58b6fd8afeba87980b mousepad.post-deinstall"
+md5sums="d98854edb76d823ac20b266fdf5a64a1 mousepad-0.2.16.tar.bz2"
diff --git a/main/mousepad/mousepad.post-deinstall b/main/mousepad/mousepad.post-deinstall
deleted file mode 120000
index 4e963a9a0..000000000
--- a/main/mousepad/mousepad.post-deinstall
+++ /dev/null
@@ -1 +0,0 @@
-mousepad.post-install \ No newline at end of file
diff --git a/main/mousepad/mousepad.post-install b/main/mousepad/mousepad.post-install
deleted file mode 100644
index e20da06b3..000000000
--- a/main/mousepad/mousepad.post-install
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-
-update-desktop-database -q
-