summaryrefslogtreecommitdiffstats
path: root/main/mp3splt-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-18 11:46:12 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-18 11:46:12 +0000
commitf15278315a3ded2adaf5caf5061c9ecabf836676 (patch)
treee9acc3d8bd6facea3f4ff2e0682c2a66f8ba193e /main/mp3splt-gtk
parent685640eec24e6fa6ce4b5983920fef42f75ae9de (diff)
downloadaports-f15278315a3ded2adaf5caf5061c9ecabf836676.tar.bz2
aports-f15278315a3ded2adaf5caf5061c9ecabf836676.tar.xz
main/mp3split-gtk: fix underlinking
Diffstat (limited to 'main/mp3splt-gtk')
-rw-r--r--main/mp3splt-gtk/APKBUILD12
-rw-r--r--main/mp3splt-gtk/dbus-glib-underlinking.patch27
2 files changed, 35 insertions, 4 deletions
diff --git a/main/mp3splt-gtk/APKBUILD b/main/mp3splt-gtk/APKBUILD
index f8b83a6de..d04162e76 100644
--- a/main/mp3splt-gtk/APKBUILD
+++ b/main/mp3splt-gtk/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mp3splt-gtk
pkgver=0.7
-pkgrel=0
+pkgrel=1
pkgdesc="Gtk frontend for mp3splt"
url="http://mp3splt.sourceforge.net/"
arch="all"
license="GPLv2"
depends=""
makedepends="gtk+-dev gst-plugins-base-dev gnome-doc-utils libmp3splt-dev
- audacious-dev"
+ audacious-dev
+ autoconf automake libtool"
install=""
subpackages="$pkgname-doc $pkgname-lang"
-source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-gtk-$pkgver.tar.gz"
+source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-gtk-$pkgver.tar.gz
+ dbus-glib-underlinking.patch"
_builddir="$srcdir"/mp3splt-gtk-$pkgver
prepare() {
@@ -23,6 +25,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ aclocal && autoreconf
}
build() {
@@ -39,4 +42,5 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="a1cefffb7ea78ae7c07c8d3ba7a2630b mp3splt-gtk-0.7.tar.gz"
+md5sums="a1cefffb7ea78ae7c07c8d3ba7a2630b mp3splt-gtk-0.7.tar.gz
+9531efb02e98624356bda87c92be7cce dbus-glib-underlinking.patch"
diff --git a/main/mp3splt-gtk/dbus-glib-underlinking.patch b/main/mp3splt-gtk/dbus-glib-underlinking.patch
new file mode 100644
index 000000000..87623236e
--- /dev/null
+++ b/main/mp3splt-gtk/dbus-glib-underlinking.patch
@@ -0,0 +1,27 @@
+diff --git a/configure.ac b/configure.ac
+index bddace0..b4bb928 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -121,6 +121,9 @@ AC_MSG_RESULT($HOST)
+ #check for -lm
+ AC_CHECK_LIB(m, pow, [ haslm="yes" ] , [ AC_MSG_ERROR([libm not found !]) ] )
+
++# check for dbus-glib
++PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1)
++
+ #################################################
+ # Initialize the gnome integration
+ #################################################
+diff --git a/src/Makefile.am b/src/Makefile.am
+index fce2976..6e80355 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -48,7 +48,7 @@ mp3splt_gtk_SOURCES = \
+
+ INCLUDES = @GTK_CFLAGS@ @MP3SPLT_CFLAGS@
+
+-mp3splt_gtk_LDADD = @GTK_LIBS@ -lgthread-2.0 @MP3SPLT_LIBS@ -lm
++mp3splt_gtk_LDADD = @GTK_LIBS@ -lgthread-2.0 @MP3SPLT_LIBS@ @DBUS_GLIB_LIBS@ -lm
+
+ # Define a C macro LOCALEDIR indicating where catalogs will be installed.
+ localedir = $(datadir)/locale