summaryrefslogtreecommitdiffstats
path: root/main/net-snmp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-08-21 08:43:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-21 08:43:25 +0000
commitfd5b60a8060f5116f5778db9c199ec54a423fc51 (patch)
treee84d27c20af3f7a27c030bc8e281fbb656d4c724 /main/net-snmp
parent6142be639a93b8d39945622a802c6c122bd80859 (diff)
downloadaports-fd5b60a8060f5116f5778db9c199ec54a423fc51.tar.bz2
aports-fd5b60a8060f5116f5778db9c199ec54a423fc51.tar.xz
main/net-snmp: fix parallel build issues
We need run net-snmp-config-x before building perl modules. Otherwise net-snmp-config will not be executable and net-snmp-config --libs will fail and perl modules will be built without -lnetsnmp. Seems also that we need build startnadall and net-snmp-create-v3-user before building perl modules. We could have "fixed" it by simply disabling parallel builds, but I don't like the idea of having 1 core working and 7 cores in idle. fixes #1263
Diffstat (limited to 'main/net-snmp')
-rw-r--r--main/net-snmp/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/main/net-snmp/APKBUILD b/main/net-snmp/APKBUILD
index 03da23fed..32d03e947 100644
--- a/main/net-snmp/APKBUILD
+++ b/main/net-snmp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=net-snmp
pkgver=5.7.1
-pkgrel=5
+pkgrel=6
pkgdesc="Simple Network Management Protocol"
url="http://www.net-snmp.org/"
arch="all"
@@ -60,6 +60,7 @@ build() {
--enable-ucd-snmp-compatibility \
--with-persistent-directory="/var/lib/net-snmp" \
--with-openssl \
+ --enable-pic \
--enable-ipv6 \
--enable-shared \
--enable-as-needed \
@@ -68,8 +69,11 @@ build() {
# embedded-perl seems to create TEXTREL's
# work around parallell build issue
- make sedscript && make -j1 -C man || return 1
- make || return 1
+ make sedscript EXAMPLE.conf net-snmp-config-x \
+ && make -j1 -C man \
+ && make standardall \
+ && make net-snmp-create-v3-user \
+ && make || return 1
}
package() {