summaryrefslogtreecommitdiffstats
path: root/main/newt
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-20 14:47:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-20 14:49:03 +0000
commit5d568f0381ad4cf41354cec0bd3e7e12d3f05d60 (patch)
tree84ad9f8ff9d456ccc10dd0acefe6384aa00357dc /main/newt
parent769f0c906507c54ea836aeb3fc85f075ca723691 (diff)
downloadaports-5d568f0381ad4cf41354cec0bd3e7e12d3f05d60.tar.bz2
aports-5d568f0381ad4cf41354cec0bd3e7e12d3f05d60.tar.xz
main/newt: upgrade to 0.52.11
and create py-newt sub package
Diffstat (limited to 'main/newt')
-rw-r--r--main/newt/APKBUILD18
-rw-r--r--main/newt/newt-0.52.7-notcl.patch35
2 files changed, 12 insertions, 41 deletions
diff --git a/main/newt/APKBUILD b/main/newt/APKBUILD
index c87d36e98..858ecd265 100644
--- a/main/newt/APKBUILD
+++ b/main/newt/APKBUILD
@@ -1,20 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=newt
-pkgver=0.52.10
-pkgrel=1
+pkgver=0.52.11
+pkgrel=0
pkgdesc="Redhat's Newt windowing toolkit development files"
url="https://fedorahosted.org/newt/"
license="LGPL-2"
depends=
makedepends="slang-dev popt-dev python-dev ncurses-dev wget"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc py-newt:py"
source="https://fedorahosted.org/releases/n/e/newt/newt-$pkgver.tar.gz
- $pkgname-0.52.7-notcl.patch
"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
for i in ../*.patch; do
+ [ -r "$i" ] || continue
msg "Applying $i..."
patch -p1 < $i || return 1
done
@@ -38,5 +38,11 @@ package() {
make -j1 DESTDIR="$pkgdir" prefix="/usr" RPM_OPT_FLAGS="ERROR" install \
|| true
}
-md5sums="bcbcc87ec19ba37d34f819209afa2e15 newt-0.52.10.tar.gz
-6780156f3b66a3f05efe1ee821617031 newt-0.52.7-notcl.patch"
+
+py() {
+ pkgdesc="A NEWT module for Python"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="4b9a0685ecd180c42d2c4a5806e3fc52 newt-0.52.11.tar.gz"
diff --git a/main/newt/newt-0.52.7-notcl.patch b/main/newt/newt-0.52.7-notcl.patch
deleted file mode 100644
index b9f86e6b6..000000000
--- a/main/newt/newt-0.52.7-notcl.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- newt-0.52.7/Makefile.in.orig 2008-01-15 16:57:12.000000000 +0100
-+++ newt-0.52.7/Makefile.in 2008-01-15 16:58:38.000000000 +0100
-@@ -15,7 +15,7 @@
- PYTHONVERS = @PYTHONVERS@
- WHIPTCLSO = @WHIPTCLSO@
-
--PROGS = test whiptail $(WHIPTCLSO) testgrid testtree showchars showkey
-+PROGS = test whiptail testgrid testtree showchars showkey
- TESTOBJS = test.o testgrid.o testtree.o showchars.o showkey.o
- NDIALOGOBJS = whiptail.o dialogboxes.o
- WHIPTCLOBJS = shared/whiptcl.o shared/dialogboxes.o
-@@ -78,9 +78,6 @@
- whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
- $(CC) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
-
--whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
-- $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lslang -lpopt -lm
--
- $(LIBNEWT): $(LIBOBJS)
- ar rv $@ $^
-
-@@ -120,12 +117,11 @@
- install -m 644 whiptail.1 $(instroot)/$(man1dir)
- make -C po datadir=$(instroot)/$(datadir) install
-
--install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
-+install-sh: sharedlib _snackmodule.so
- [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
- install -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
- ln -sf $(LIBNEWTSONAME) $(instroot)/$(libdir)/libnewt.so
- ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/$(LIBNEWTSONAME)
-- [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so $(instroot)/$(libdir) || :
- for ver in $(PYTHONVERS) ; do \
- [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
- install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\