summaryrefslogtreecommitdiffstats
path: root/main/obex-data-server
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-08-20 17:56:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-21 07:29:41 +0000
commit60974eb1386a1f60fe99ece132e2c8855b3699b7 (patch)
treee36381ff3f545f5507454a559a25d5521e8cf4ea /main/obex-data-server
parentcb1665d5d572f972f42465d9ad8d4426456118cd (diff)
downloadaports-60974eb1386a1f60fe99ece132e2c8855b3699b7.tar.bz2
aports-60974eb1386a1f60fe99ece132e2c8855b3699b7.tar.xz
main/obex-data-server: build fix
Diffstat (limited to 'main/obex-data-server')
-rw-r--r--main/obex-data-server/APKBUILD18
-rw-r--r--main/obex-data-server/obex-data-server-0.4.6-build-fixes-1.patch56
2 files changed, 70 insertions, 4 deletions
diff --git a/main/obex-data-server/APKBUILD b/main/obex-data-server/APKBUILD
index 0884138c4..580b512ef 100644
--- a/main/obex-data-server/APKBUILD
+++ b/main/obex-data-server/APKBUILD
@@ -9,11 +9,20 @@ arch="all"
depends="!obexd"
subpackages="$pkgname-doc"
makedepends="dbus-glib-dev openobex-dev gtk+-dev libusb-compat-dev bluez-dev"
-source="http://tadas.dailyda.com/software/obex-data-server-$pkgver.tar.gz"
+source="http://tadas.dailyda.com/software/obex-data-server-$pkgver.tar.gz
+ obex-data-server-0.4.6-build-fixes-1.patch"
_builddir="$srcdir"/$pkgname-$pkgver
-build ()
-{
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
cd $srcdir/$pkgname-$pkgver
./configure --prefix=/usr \
--sysconfdir=/etc \
@@ -26,4 +35,5 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="961ca5db6fe9c97024e133cc6203cc4d obex-data-server-0.4.6.tar.gz"
+md5sums="961ca5db6fe9c97024e133cc6203cc4d obex-data-server-0.4.6.tar.gz
+7662a16e6b85b0e42a8a0fbf3ecd6d33 obex-data-server-0.4.6-build-fixes-1.patch"
diff --git a/main/obex-data-server/obex-data-server-0.4.6-build-fixes-1.patch b/main/obex-data-server/obex-data-server-0.4.6-build-fixes-1.patch
new file mode 100644
index 000000000..b5fde8db5
--- /dev/null
+++ b/main/obex-data-server/obex-data-server-0.4.6-build-fixes-1.patch
@@ -0,0 +1,56 @@
+Submitted By: Armin K. <krejzi at email dot com>
+Date: 2012-07-06
+Initial Package Version: 0.4.6
+Upstream Status: Unknown
+Origin: Self
+Description: Some build fixes.
+
+--- obex-data-server.orig/src/ods-obex.c 2011-02-10 10:14:42.000000000 +0100
++++ obex-data-server/src/ods-obex.c 2012-07-06 20:10:09.208712553 +0200
+@@ -412,7 +412,7 @@
+ goto err;
+ }
+
+- interfaces_num = OBEX_FindInterfaces(obex_context->obex_handle, &obex_intf);
++ interfaces_num = OBEX_EnumerateInterfaces(obex_context->obex_handle);
+ if (intf_num >= interfaces_num) {
+ g_set_error (error, ODS_ERROR, ODS_ERROR_FAILED, "Invalid interface number");
+ goto err;
+@@ -1928,7 +1928,7 @@
+ gchar *uname;
+ gsize uname_len;
+
+- if (action != OBEX_ACTION_SETPERM)
++ if (action != 0x03)
+ g_assert (src && dst);
+
+ object = OBEX_ObjectNew (obex_context->obex_handle, OBEX_CMD_ACTION);
+@@ -1974,7 +1974,7 @@
+ OBEX_HDR_ACTION_ID, hv, 1, 0);
+
+ /* permissions header */
+- if (action == OBEX_ACTION_SETPERM) {
++ if (action == 0x03) {
+ hv.bq4 = perms;
+ ret = OBEX_ObjectAddHeader (obex_context->obex_handle, object,
+ OBEX_HDR_PERMISSIONS, hv, 4, 0);
+--- obex-data-server.orig/src/ods-session.c 2011-02-10 09:57:31.000000000 +0100
++++ obex-data-server/src/ods-session.c 2012-07-06 20:10:09.208712553 +0200
+@@ -1761,7 +1761,7 @@
+ DBusGMethodInvocation *context)
+ {
+ return ods_session_remote_action (session, remote_source,
+- remote_destination, OBEX_ACTION_COPY,
++ remote_destination, 0x00,
+ context);
+ }
+
+@@ -1772,7 +1772,7 @@
+ DBusGMethodInvocation *context)
+ {
+ return ods_session_remote_action (session, remote_source,
+- remote_destination, OBEX_ACTION_MOVE,
++ remote_destination, 0x01,
+ context);
+ }
+