summaryrefslogtreecommitdiffstats
path: root/main/obexd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-07 05:58:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-07 05:58:52 +0000
commita5a583e7d11705cb580c08466b2d476bca718bc1 (patch)
treed6c1dbccf9ffb33833b32c107e58d434ba5e2c50 /main/obexd
parentbeb1b1720862c18461a3488b1c15211df9c9ce14 (diff)
downloadaports-a5a583e7d11705cb580c08466b2d476bca718bc1.tar.bz2
aports-a5a583e7d11705cb580c08466b2d476bca718bc1.tar.xz
main/gnome-bluetooth(and dependencies): moved from testing
Diffstat (limited to 'main/obexd')
-rw-r--r--main/obexd/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/obexd/APKBUILD b/main/obexd/APKBUILD
new file mode 100644
index 000000000..5e6087284
--- /dev/null
+++ b/main/obexd/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=obexd
+pkgver=0.40
+pkgrel=1
+pkgdesc="D-Bus service for Obex Server"
+url="http://www.bluez.org/"
+arch="all"
+license="GPL2"
+depends="!obex-data-server"
+subpackages="$pkgname-client"
+makedepends="dbus-glib-dev openobex-dev glib-dev bluez-dev libical-dev"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/obexd \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+_mv_files() {
+ local i
+ for i in "$@"; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv "$pkgdir"/$i "$subpkgdir"/$i || return 1
+ done
+}
+
+client() {
+ pkgdesc="D-Bus service for Obex Client access"
+ depends=
+ cd "$pkgdir"
+ _mv_files usr/lib/obexd/obex-client \
+ usr/share/dbus-*/services/obex-client.service
+}
+
+md5sums="f303592b7664b246965c1d6e9361c919 obexd-0.40.tar.bz2"