summaryrefslogtreecommitdiffstats
path: root/main/openrc/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-04-13 07:03:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-04-13 07:25:03 +0000
commitf1e34f1dffbaa883e8733dfc5dafb6b1293c4e45 (patch)
treee5088f144f62cd6653ad83f99a481f12731fe3cd /main/openrc/APKBUILD
parent2d116ff62c2f3bc5e25fafaadde1eb750c1b8096 (diff)
downloadaports-f1e34f1dffbaa883e8733dfc5dafb6b1293c4e45.tar.bz2
aports-f1e34f1dffbaa883e8733dfc5dafb6b1293c4e45.tar.xz
main/openrc: move /libexec/rc to /lib/rc to be more FHS compat
Also clean up the /etc/rc.local compat. We now in the post-upgrade look if there are any /etc/rc.local and if there are we create an /etc/local.d/rc.local-compat.start script, otherwise we just let it be.
Diffstat (limited to 'main/openrc/APKBUILD')
-rw-r--r--main/openrc/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index e71772994..04d93ace5 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.8.0
_ver=${pkgver/_git*/}
-pkgrel=0
+pkgrel=1
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
@@ -22,7 +22,6 @@ source="http://distfiles.gentoo.org/distfiles/$pkgname-$_ver.tar.bz2
modules.initd
modloop.initd
networking.initd
- local.start
modloop.confd
"
@@ -39,12 +38,12 @@ prepare() {
build() {
cd "$_builddir"
- make || return 1
+ make LIBEXECDIR=/lib/rc || return 1
}
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir/" install
+ make LIBEXECDIR=/lib/rc DESTDIR="$pkgdir/" install
# we cannot have anything turned on by default
rm -f "$pkgdir"/etc/runlevels/*/*
@@ -53,13 +52,13 @@ package() {
rm -f "$pkgdir"/etc/conf.d/network "$pkgdir"/etc/init.d/network
# we override some of the scripts
- for i in ../*.initd; do
+ for i in "$srcdir"/*.initd; do
j=${i##*/}
install -Dm755 $i "$pkgdir"/etc/init.d/${j%.initd}
done
install -D -m644 "$srcdir"/modloop.confd "$pkgdir"/etc/conf.d/modloop
- install -Dm644 ../local.start "$pkgdir"/etc/conf.d/local.start
+ install -d "$pkgdir"/etc/local.d
}
md5sums="54978ba3a1ff9fb8f04aae422c0416af openrc-0.8.0.tar.bz2
@@ -72,5 +71,4 @@ b1e64885f301166df30be3e3cf5338ff hwdrivers.initd
098a1f16812f56fcb56eb6b6f0fa31f6 modules.initd
408e28f247c7cc71fa104c07869417f4 modloop.initd
af16db0d798392c7c0ed3434e4bad241 networking.initd
-0a615d93aab691364c03539c3b496dcc local.start
c1ec888202d868710b5749f7b217d1e3 modloop.confd"