summaryrefslogtreecommitdiffstats
path: root/main/perl-cps
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:40:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 10:40:08 +0000
commit6618fccfa813e0ac0ff9629af45c1f8420b43345 (patch)
tree6ba0ae5264e290b2a5228a3df1035935decb2086 /main/perl-cps
parent1f2f63b9d154115bf0caac1c8483161c869c7a77 (diff)
downloadaports-6618fccfa813e0ac0ff9629af45c1f8420b43345.tar.bz2
aports-6618fccfa813e0ac0ff9629af45c1f8420b43345.tar.xz
main/perl-cps: moved to main
Diffstat (limited to 'main/perl-cps')
-rw-r--r--main/perl-cps/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/perl-cps/APKBUILD b/main/perl-cps/APKBUILD
new file mode 100644
index 000000000..1b1aaab0a
--- /dev/null
+++ b/main/perl-cps/APKBUILD
@@ -0,0 +1,38 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-cps
+_pkgreal=CPS
+pkgver=0.11
+pkgrel=0
+pkgdesc="manage flow of control in Continuation-Passing Style"
+url="http://search.cpan.org/dist/CPS/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ perl Build.PL installdirs=vendor || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="e4f36f053f538a6fa1ea4ed1de038f9e CPS-0.11.tar.gz"