summaryrefslogtreecommitdiffstats
path: root/main/perl-test-exception
diff options
context:
space:
mode:
authorMika Havela <mika.havela@gmail.com>2010-11-26 16:09:18 +0100
committerMika Havela <mika.havela@gmail.com>2010-11-26 16:09:18 +0100
commit46888b93c0d13bfc991dcaf8eef691fd440dd615 (patch)
treec8047ed4067e8abed620aa61c9089b1172201f47 /main/perl-test-exception
parent7166567e590773f1b2d14a09475baf58d1e17f30 (diff)
downloadaports-46888b93c0d13bfc991dcaf8eef691fd440dd615.tar.bz2
aports-46888b93c0d13bfc991dcaf8eef691fd440dd615.tar.xz
testing/perl-test-exception: Moved to main
Used together with swatch. Confirmed that it works.
Diffstat (limited to 'main/perl-test-exception')
-rw-r--r--main/perl-test-exception/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/perl-test-exception/APKBUILD b/main/perl-test-exception/APKBUILD
new file mode 100644
index 000000000..7b276c63d
--- /dev/null
+++ b/main/perl-test-exception/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Mika Havela <mika.havela@gmail.com>
+# Maintainer: Mika Havela <mika.havela@gmail.com>
+pkgname=perl-test-exception
+_realname=Test-Exception
+pkgver=0.29
+pkgrel=0
+pkgdesc="Perl - Test exception based code"
+url="http://search.cpan.org/~adie/$_realname-$pkgver/"
+license="Artistic GPL"
+depends="perl perl-sub-uplevel"
+makedepends="perl-dev"
+#subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADIE/$_realname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+ # creates file collision among perl modules
+ find "$pkgdir" -name perllocal.pod -delete
+}
+
+md5sums="9aea475db531d4fd4ce40cf25a0acd14 Test-Exception-0.29.tar.gz"