summaryrefslogtreecommitdiffstats
path: root/main/perl-www-robotrules
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-01 13:12:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-01 13:12:31 +0000
commit9202f7c1c9e2c6b73ac317550376dd54f970b72e (patch)
treefa2bc08b3cf6936e45b4dd96cdcf5b97564fb139 /main/perl-www-robotrules
parent4e3cd93afabd3b76e7ac75062ed099f55e3e9b0f (diff)
downloadaports-9202f7c1c9e2c6b73ac317550376dd54f970b72e.tar.bz2
aports-9202f7c1c9e2c6b73ac317550376dd54f970b72e.tar.xz
main/perl-www-robotrules: new aport needed by perl-libwww
WWW::RobotRules perl module http://search.cpan.org/dist/WWW-RobotRules/
Diffstat (limited to 'main/perl-www-robotrules')
-rw-r--r--main/perl-www-robotrules/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/perl-www-robotrules/APKBUILD b/main/perl-www-robotrules/APKBUILD
new file mode 100644
index 000000000..be306990d
--- /dev/null
+++ b/main/perl-www-robotrules/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-www-robotrules
+pkgver=6.01
+pkgrel=0
+pkgdesc="WWW::RobotRules perl module"
+url="http://search.cpan.org/dist/WWW-RobotRules/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl perl-uri"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/WWW-RobotRules-$pkgver.tar.gz"
+
+_builddir="$srcdir"/WWW-RobotRules-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="b1252da49727320a1b5e20b3521d2499 WWW-RobotRules-6.01.tar.gz"