summaryrefslogtreecommitdiffstats
path: root/main/pllua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-23 14:58:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-23 15:33:09 +0000
commit2337172c6c89365754381b32857c3d9b492f6f69 (patch)
tree79fede541708a4c0affef708d05e32d83d22e5c8 /main/pllua
parent047e97b499cd12b5e9d52a3874818646752ca4de (diff)
downloadaports-2337172c6c89365754381b32857c3d9b492f6f69.tar.bz2
aports-2337172c6c89365754381b32857c3d9b492f6f69.tar.xz
main/pllua: upgrade to 0.3.2
Diffstat (limited to 'main/pllua')
-rw-r--r--main/pllua/APKBUILD40
-rw-r--r--main/pllua/pllua-01-0.3.1-include.patch14
-rw-r--r--main/pllua/pllua-include.patch10
3 files changed, 31 insertions, 33 deletions
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
index ed1642749..ca0d1cd1b 100644
--- a/main/pllua/APKBUILD
+++ b/main/pllua/APKBUILD
@@ -1,37 +1,39 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=pllua
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=0
pkgdesc="Procedural language for PostgreSQL using Lua"
url="http://pgfoundry.org/projects/pllua"
arch="all"
license="GPL"
depends="postgresql"
-makedepends="postgresql-dev lua-dev ccache"
+makedepends="postgresql-dev lua-dev"
install=
subpackages=""
-source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
- pllua-01-0.3.1-include.patch"
+source="
+ http://pgfoundry.org/frs/download.php/2401/pllua-$pkgver.tar.gz
+ pllua-include.patch"
-# append extra dependencies to -dev subpackage
-# remove if not used.
-# depends_dev="somepackage-dev"
+_builddir="$srcdir"/pllua-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
- for i in "$srcdir"/*.patch; do
- msg "Applying ${i}"
- patch -p1 -i $i || return 1
- done
-
+ cd "$_builddir"
make || return 1
- make DESTDIR="$pkgdir" install
+}
- # remove the 2 lines below (and this) if there is no init.d script
- # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
}
-md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
-a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"
+md5sums="e91cbbaa0bbaca9bd4478255a98a264e pllua-0.3.2.tar.gz
+a0b6b84f0fb7776c70ed1052ae4f2c8e pllua-include.patch"
diff --git a/main/pllua/pllua-01-0.3.1-include.patch b/main/pllua/pllua-01-0.3.1-include.patch
deleted file mode 100644
index afbf8a984..000000000
--- a/main/pllua/pllua-01-0.3.1-include.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-#most of fix from here http://postgis.refractions.net/pipermail/postgis-devel/2009-February/004879.html
---- pllua-0.3.1/plluaapi.c.orig Thu Sep 17 15:34:07 2009
-+++ pllua-0.3.1/plluaapi.c Thu Sep 17 15:34:18 2009
-@@ -7,6 +7,10 @@
-
- #include "pllua.h"
- #include "rowstamp.h"
-+#include "utils/guc.h"
-+extern Datum textout (PG_FUNCTION_ARGS);
-+extern Datum bpcharout(PG_FUNCTION_ARGS);
-+extern Datum varcharout(PG_FUNCTION_ARGS);
-
- /* extended function info */
- typedef struct luaP_Info {
diff --git a/main/pllua/pllua-include.patch b/main/pllua/pllua-include.patch
new file mode 100644
index 000000000..886efc9e5
--- /dev/null
+++ b/main/pllua/pllua-include.patch
@@ -0,0 +1,10 @@
+--- ./pllua.h.orig Tue Oct 9 17:32:18 2012
++++ ./pllua.h Tue Oct 9 17:32:27 2012
+@@ -25,6 +25,7 @@
+ #include <utils/datum.h>
+ #include <utils/builtins.h>
+ #include <utils/array.h>
++#include <utils/rel.h>
+ /* Lua */
+ #include <lua.h>
+ #include <lualib.h>