summaryrefslogtreecommitdiffstats
path: root/main/pllua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-31 09:12:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-31 09:12:47 +0000
commitcba9c7336ccdbcd072e2d2e6009b34431f125be0 (patch)
treec09c3ce91fdb9ecc3626619d2198c7a93f5b6e04 /main/pllua
parent01773274eaff18408737aa5bbad49358fc6826c3 (diff)
downloadaports-cba9c7336ccdbcd072e2d2e6009b34431f125be0.tar.bz2
aports-cba9c7336ccdbcd072e2d2e6009b34431f125be0.tar.xz
main/pllua: moved from testing
Diffstat (limited to 'main/pllua')
-rw-r--r--main/pllua/APKBUILD37
-rw-r--r--main/pllua/pllua-01-0.3.1-include.patch14
2 files changed, 51 insertions, 0 deletions
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
new file mode 100644
index 000000000..913f99bbd
--- /dev/null
+++ b/main/pllua/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Maintainer: Michael Mason <ms13sp@gmail.com>
+pkgname=pllua
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="Procedural language for PostgreSQL using Lua"
+url="http://pgfoundry.org/projects/pllua"
+arch="x86 x86_64"
+license="GPL"
+depends="postgresql"
+makedepends="postgresql-dev lua-dev ccache"
+install=
+subpackages=""
+source="http://pgfoundry.org/frs/download.php/1722/$pkgname-$pkgver.tar.gz
+ pllua-01-0.3.1-include.patch"
+
+# append extra dependencies to -dev subpackage
+# remove if not used.
+# depends_dev="somepackage-dev"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ msg "Applying ${i}"
+ patch -p1 -i $i || return 1
+ done
+
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="e57385bdf2d533ac73cd02401795cea8 pllua-0.3.1.tar.gz
+a47387e64b7dba8d58237c7dad0e2d61 pllua-01-0.3.1-include.patch"
diff --git a/main/pllua/pllua-01-0.3.1-include.patch b/main/pllua/pllua-01-0.3.1-include.patch
new file mode 100644
index 000000000..afbf8a984
--- /dev/null
+++ b/main/pllua/pllua-01-0.3.1-include.patch
@@ -0,0 +1,14 @@
+#most of fix from here http://postgis.refractions.net/pipermail/postgis-devel/2009-February/004879.html
+--- pllua-0.3.1/plluaapi.c.orig Thu Sep 17 15:34:07 2009
++++ pllua-0.3.1/plluaapi.c Thu Sep 17 15:34:18 2009
+@@ -7,6 +7,10 @@
+
+ #include "pllua.h"
+ #include "rowstamp.h"
++#include "utils/guc.h"
++extern Datum textout (PG_FUNCTION_ARGS);
++extern Datum bpcharout(PG_FUNCTION_ARGS);
++extern Datum varcharout(PG_FUNCTION_ARGS);
+
+ /* extended function info */
+ typedef struct luaP_Info {